summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2016-06-09 08:16:51 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-10 08:02:42 +0700
commita89dcbec0d12a8165d69ffd1b3834fddb4c0cfb7 (patch)
treef748fa5d33fc3d242589bbb72741ea16ae0ebded /graphics
parent69f2751109f476b8b6824755b0d664f300bf2247 (diff)
downloadslackbuilds-a89dcbec0d12a8165d69ffd1b3834fddb4c0cfb7.tar.gz
slackbuilds-a89dcbec0d12a8165d69ffd1b3834fddb4c0cfb7.tar.xz
gis/CreateCloudMap: Moved from graphics/ category.
Signed-off-by: David Spencer <baildon.research@googlemail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/CreateCloudMap/CreateCloudMap.SlackBuild88
-rw-r--r--graphics/CreateCloudMap/CreateCloudMap.info10
-rw-r--r--graphics/CreateCloudMap/README5
-rw-r--r--graphics/CreateCloudMap/doinst.sh3
-rw-r--r--graphics/CreateCloudMap/slack-desc19
5 files changed, 0 insertions, 125 deletions
diff --git a/graphics/CreateCloudMap/CreateCloudMap.SlackBuild b/graphics/CreateCloudMap/CreateCloudMap.SlackBuild
deleted file mode 100644
index d1e62d9d9d..0000000000
--- a/graphics/CreateCloudMap/CreateCloudMap.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for CreateCloudMap
-
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=CreateCloudMap
-VERSION=${VERSION:-0.5.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/CreateCloudMap/CreateCloudMap.info b/graphics/CreateCloudMap/CreateCloudMap.info
deleted file mode 100644
index 2c300c267a..0000000000
--- a/graphics/CreateCloudMap/CreateCloudMap.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="CreateCloudMap"
-VERSION="0.5.1"
-HOMEPAGE="https://github.com/jmozmoz/cloudmap"
-DOWNLOAD="https://pypi.python.org/packages/source/C/CreateCloudMap/CreateCloudMap-0.5.1.tar.gz"
-MD5SUM="d4f8cf00aaccfdb7ec58dae6f8b4c929"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyresample scipy python-requests DateTime ConfigParser"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/graphics/CreateCloudMap/README b/graphics/CreateCloudMap/README
deleted file mode 100644
index f38ad22afa..0000000000
--- a/graphics/CreateCloudMap/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Python script to create a cloud map for xplanet using satellite images from the
-Dundee Satellite Receiving Station, Dundee University, UK.
-
-Optional :
-xplanet can use a cloud map to make the earth look more pretty.
diff --git a/graphics/CreateCloudMap/doinst.sh b/graphics/CreateCloudMap/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/graphics/CreateCloudMap/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/graphics/CreateCloudMap/slack-desc b/graphics/CreateCloudMap/slack-desc
deleted file mode 100644
index 07404c420e..0000000000
--- a/graphics/CreateCloudMap/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-CreateCloudMap: CreateCloudMap (cloud map for xplanet)
-CreateCloudMap:
-CreateCloudMap: Python script to create a cloud map for xplanet using satellite
-CreateCloudMap: images from the Dundee Satellite Receiving Station, Dundee
-CreateCloudMap: University, UK.
-CreateCloudMap:
-CreateCloudMap: Homepage: https://github.com/jmozmoz/cloudmap
-CreateCloudMap:
-CreateCloudMap:
-CreateCloudMap:
-CreateCloudMap: