summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-12-15 09:12:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-17 09:40:16 +0700
commitbcbebf33abec328c1065cf773031aadd6b343b91 (patch)
treec871169dc5a9a9d400a01bb47aa263066ee86233 /graphics
parent04cda44a4278fcf2dfaf1b2c92a3c54092cecbf1 (diff)
downloadslackbuilds-bcbebf33abec328c1065cf773031aadd6b343b91.tar.gz
slackbuilds-bcbebf33abec328c1065cf773031aadd6b343b91.tar.xz
graphics/digikam: Patched to build against newer lensfun and flex
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/digikam/digikam.SlackBuild11
-rw-r--r--graphics/digikam/lensfun-0.3.2.patch26
2 files changed, 36 insertions, 1 deletions
diff --git a/graphics/digikam/digikam.SlackBuild b/graphics/digikam/digikam.SlackBuild
index fc091e3977..9674fcfaa3 100644
--- a/graphics/digikam/digikam.SlackBuild
+++ b/graphics/digikam/digikam.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=digikam
VERSION=${VERSION:-4.14.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,6 +66,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+cd core
+# patch for lensfun 0.3.2
+patch -p1 < $CWD/lensfun-0.3.2.patch
+
+# workaround for flex-2.6.0
+sed -e '/fno-tree-pre/d' -i CMakeLists.txt
+cd ..
+
mkdir -p build
cd build
cmake \
@@ -83,6 +91,7 @@ cd build
-DDIGIKAMSC_COMPILE_DOC=OFF \
-DCMAKE_CXX_FLAGS:STRING="$(/usr/bin/Magick++-config --libs)" \
-DENABLE_OPENCV3=ON \
+ -DCMAKE_C_COMPILER=clang \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
diff --git a/graphics/digikam/lensfun-0.3.2.patch b/graphics/digikam/lensfun-0.3.2.patch
new file mode 100644
index 0000000000..37776f6e31
--- /dev/null
+++ b/graphics/digikam/lensfun-0.3.2.patch
@@ -0,0 +1,26 @@
+From: Gilles Caulier <caulier.gilles@gmail.com>
+Date: Mon, 14 Dec 2015 21:41:55 +0000
+Subject: fix compilation with Lensfun 0.3.2
+X-Git-Url: http://quickgit.kde.org/?p=digikam.git&a=commitdiff&h=0f159981176faa6da701f112bfe557b79804d468
+---
+fix compilation with Lensfun 0.3.2
+It still compatible with older lensfun releases.
+BUGS: 356672
+FIXED-IN: 5.0.0
+---
+
+
+--- a/libs/dimg/filters/lens/lensfuniface.h
++++ b/libs/dimg/filters/lens/lensfuniface.h
+@@ -24,10 +24,7 @@
+
+ // Lib LensFun includes
+
+-extern "C"
+-{
+ #include <lensfun.h>
+-}
+
+ // Local includes
+
+