summaryrefslogtreecommitdiffstats
path: root/libraries/BeautifulSoup4
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2020-05-22 21:36:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-05-22 23:36:13 +0700
commit8a62cd46201c9cdce19915fcacb6541e8e326ae9 (patch)
tree00f1de983c5b0e66f6607a078f1fcc896309c9cb /libraries/BeautifulSoup4
parenta289f8b6c7d2a91bafc485fc50ed9cb6f1c899b0 (diff)
downloadslackbuilds-8a62cd46201c9cdce19915fcacb6541e8e326ae9.tar.gz
slackbuilds-8a62cd46201c9cdce19915fcacb6541e8e326ae9.tar.xz
python/BeautifulSoup4: Updated for v 4.9.1, moved from libraries.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/BeautifulSoup4')
-rw-r--r--libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild107
-rw-r--r--libraries/BeautifulSoup4/BeautifulSoup4.info10
-rw-r--r--libraries/BeautifulSoup4/README31
-rw-r--r--libraries/BeautifulSoup4/slack-desc19
4 files changed, 0 insertions, 167 deletions
diff --git a/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild b/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
deleted file mode 100644
index 5fe2f506d4..0000000000
--- a/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for BeautifulSoup4
-
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=BeautifulSoup4
-VERSION=${VERSION:-4.9.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=beautifulsoup4
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if $(python2 -c 'import soupsieve' 2>/dev/null); then
- python setup.py install --root=$PKG
-fi
-
-# Python 3 support (requires python3-soupsieve)
-if $(python3 -c 'import soupsieve' 2>/dev/null); then
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- sed -i "s/-rfI/-rf/" convert-py3k
- sh convert-py3k
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md COPYING.txt NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/BeautifulSoup4/BeautifulSoup4.info b/libraries/BeautifulSoup4/BeautifulSoup4.info
deleted file mode 100644
index 41649766ff..0000000000
--- a/libraries/BeautifulSoup4/BeautifulSoup4.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="BeautifulSoup4"
-VERSION="4.9.0"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/"
-DOWNLOAD="https://www.crummy.com/software/BeautifulSoup/bs4/download/4.9/beautifulsoup4-4.9.0.tar.gz"
-MD5SUM="54e86045e37b578036f34b0e4927c85f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-soupsieve"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
diff --git a/libraries/BeautifulSoup4/README b/libraries/BeautifulSoup4/README
deleted file mode 100644
index 177bad7002..0000000000
--- a/libraries/BeautifulSoup4/README
+++ /dev/null
@@ -1,31 +0,0 @@
-Beautiful Soup is a Python HTML/XML parser designed for quick turnaround
-projects like screen-scraping. Three features make it powerful:
-
-1. Beautiful Soup won't choke if you give it bad markup. It yields a
-parse tree that makes approximately as much sense as your original
-document. This is usually good enough to collect the data you need
-and run away.
-
-2. Beautiful Soup provides a few simple methods and Pythonic idioms for
-navigating, searching, and modifying a parse tree: a toolkit for
-dissecting a document and extracting what you need. You don't have to
-create a custom parser for each application.
-
-3. Beautiful Soup automatically converts incoming documents to Unicode
-and outgoing documents to UTF-8. You don't have to think about
-encodings, unless the document doesn't specify an encoding and
-Beautiful Soup can't autodetect one. Then you just have to specify the
-original encoding.
-
-Beautiful Soup parses anything you give it, and does the tree traversal
-stuff for you. You can tell it "Find all the links", or "Find all the
-links of class externalLink", or "Find all the links whose urls match
-"foo.com", or "Find the table heading that's got bold text, then give
-me that text."
-
-Valuable data that was once locked up in poorly-designed websites is
-now within your reach. Projects that would have taken hours take only
-minutes with Beautiful Soup.
-
-If python3-soupsieve is installed, then this will also build for
-Python 3.
diff --git a/libraries/BeautifulSoup4/slack-desc b/libraries/BeautifulSoup4/slack-desc
deleted file mode 100644
index 2aa7bc4813..0000000000
--- a/libraries/BeautifulSoup4/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-BeautifulSoup4: BeautifulSoup4 (Python HTML/XML parser)
-BeautifulSoup4:
-BeautifulSoup4: BeautifulSoup is a Python HTML/XML parser designed for quick
-BeautifulSoup4: turnaround projects like screen-scraping
-BeautifulSoup4:
-BeautifulSoup4: Homepage: http://www.crummy.com/software/BeautifulSoup/
-BeautifulSoup4:
-BeautifulSoup4:
-BeautifulSoup4:
-BeautifulSoup4:
-BeautifulSoup4: