summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Heinz Wiesinger <HMWiesinger@gmx.at>2010-05-11 20:01:04 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:01:04 +0200
commit0eca46f72bb1be2128d14b8e6386deb57d39ab3e (patch)
tree0afa4f5a7ff33a48661111259557221f8d9e6db8 /libraries
parent9f1dbd7eef68702ab9a325bb9cd8f6959c60c268 (diff)
downloadslackbuilds-0eca46f72bb1be2128d14b8e6386deb57d39ab3e.tar.gz
slackbuilds-0eca46f72bb1be2128d14b8e6386deb57d39ab3e.tar.xz
libraries/wxPython: Added to 12.0 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/wxPython/README8
-rw-r--r--libraries/wxPython/slack-desc19
-rw-r--r--libraries/wxPython/wxPython.SlackBuild115
-rw-r--r--libraries/wxPython/wxPython.info8
4 files changed, 150 insertions, 0 deletions
diff --git a/libraries/wxPython/README b/libraries/wxPython/README
new file mode 100644
index 0000000000..681c2e2321
--- /dev/null
+++ b/libraries/wxPython/README
@@ -0,0 +1,8 @@
+wxPython is a GUI toolkit for the Python programming language. It allows
+Python programmers to create programs with a robust, highly functional
+graphical user interface simply and easily. It is implemented as a Python
+extension module (native code) that wraps the popular wxWidgets cross
+platform GUI library which is written in C++.
+
+This package conflicts with wxGTK because it's already included in wxPython.
+Both cannot be installed at the same time!
diff --git a/libraries/wxPython/slack-desc b/libraries/wxPython/slack-desc
new file mode 100644
index 0000000000..1eafdda7e6
--- /dev/null
+++ b/libraries/wxPython/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+wxPython: wxPython (Crossplatform GUI Toolkit)
+wxPython:
+wxPython: wxPython is a GUI toolkit for the Python programming language.
+wxPython: It allows Python programmers to create programs with a robust,
+wxPython: highly functional graphical user interface simply and easily.
+wxPython: It is implemented as a Python extension module (native code)
+wxPython: that wraps the popular wxWidgets cross platform GUI library
+wxPython: which is written in C++.
+wxPython:
+wxPython: Homepage: http://wxPython.org/
+wxPython:
diff --git a/libraries/wxPython/wxPython.SlackBuild b/libraries/wxPython/wxPython.SlackBuild
new file mode 100644
index 0000000000..96e4c07f23
--- /dev/null
+++ b/libraries/wxPython/wxPython.SlackBuild
@@ -0,0 +1,115 @@
+#!/bin/sh
+
+# Slackware build script for wxPython
+# Written by ppr:kut <hmwiesinger@gmx.at>
+
+# Copyright 2007 Heinz Wiesinger
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=wxPython
+VERSION=2.8.7.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-src-$VERSION
+tar xvf $CWD/$PRGNAM-src-$VERSION.tar.bz2
+cd $PRGNAM-src-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --with-sdl \
+ --with-opengl \
+ --enable-unicode
+
+make
+
+#Additional stuff needed by wxPython
+make -C contrib/src/gizmos
+make -C contrib/src/stc
+
+make install DESTDIR=$PKG
+make -C contrib/src/gizmos install DESTDIR=$PKG
+make -C contrib/src/stc install DESTDIR=$PKG
+
+cd wxPython
+ python setup.py \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ EP_ADD_OPTS=1 \
+ EP_FULL_VER=0 \
+ NO_SCRIPTS=1 \
+ WX_CONFIG="$TMP/$PRGNAM-src-$VERSION/wx-config --no_rpath" \
+ build_ext --rpath=/usr/lib \
+ build
+
+ python setup.py \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ EP_ADD_OPTS=1 \
+ EP_FULL_VER=0 \
+ NO_SCRIPTS=1 \
+ WX_CONFIG="$TMP/$PRGNAM-src-$VERSION/wx-config --prefix=$PKG/usr/bin/ --no_rpath" \
+ SYS_WX_CONFIG="wx-config --enable-unicode" \
+ build_ext --rpath=/usr/lib \
+ install --root=$PKG
+cd -
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+cp -a README.1st.txt docs* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a wxPython/docs/* $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Remove unnecessary docs
+cd $PKG/usr/doc/$PRGNAM-$VERSION/docs
+ rm -rf cocoa latex mac metrowerks microwin msw palmos word
+cd -
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/wxPython/wxPython.info b/libraries/wxPython/wxPython.info
new file mode 100644
index 0000000000..db5a5baf16
--- /dev/null
+++ b/libraries/wxPython/wxPython.info
@@ -0,0 +1,8 @@
+PRGNAM="wxPython"
+VERSION="2.8.7.1"
+HOMEPAGE="http://wxPython.org/"
+DOWNLOAD="http://downloads.sourceforge.net/wxpython/wxPython-src-2.8.7.1.tar.bz2"
+MD5SUM="04fc1079430b18e6fd097b3287e9ae10"
+MAINTAINER="ppr:kut"
+EMAIL="HMWiesinger@gmx.at"
+APPROVED="rworkman"