summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Lionel Young <redtricycle@gmail.com>2010-05-13 00:59:16 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:59:16 +0200
commit5a0a94c7a4385bc3edf5b48b69277468d558afb6 (patch)
treebdd6762bae47d81dd350eed4eb6b81239affe436 /libraries
parent3a70df7f56e91c0bf54bec571ebee9785be58214 (diff)
downloadslackbuilds-5a0a94c7a4385bc3edf5b48b69277468d558afb6.tar.gz
slackbuilds-5a0a94c7a4385bc3edf5b48b69277468d558afb6.tar.xz
libraries/python-transaction: Added to 13.0 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python-transaction/README8
-rw-r--r--libraries/python-transaction/python-transaction.SlackBuild67
-rw-r--r--libraries/python-transaction/python-transaction.info10
-rw-r--r--libraries/python-transaction/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/libraries/python-transaction/README b/libraries/python-transaction/README
new file mode 100644
index 0000000000..f80fdb9017
--- /dev/null
+++ b/libraries/python-transaction/README
@@ -0,0 +1,8 @@
+This package contains a generic transaction implementation for Python. It
+is mainly used by the ZODB, though.
+
+Note that the data manager API, transaction.interfaces.IDataManager, is
+syntactically simple, but semantically complex. The semantics were not
+easy to express in the interface. This could probably use more work. The
+semantics are presented in detail through examples of a sample data manager
+in transaction.tests.test_SampleDataManager.
diff --git a/libraries/python-transaction/python-transaction.SlackBuild b/libraries/python-transaction/python-transaction.SlackBuild
new file mode 100644
index 0000000000..9653e5355e
--- /dev/null
+++ b/libraries/python-transaction/python-transaction.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2009 Eric Hameleers <alien@slackware.com>, Eindhoven, Netherlands
+
+# Slackware build script for python-transaction
+
+# Written by Lionel Young <redtricycle@gmail.com>
+
+PRGNAM=python-transaction
+SRCNAM=transaction
+VERSION=${VERSION:-1.0.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build || exit 1
+python setup.py install --root=$PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.txt LICENSE.txt README.txt COPYRIGHT.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-transaction/python-transaction.info b/libraries/python-transaction/python-transaction.info
new file mode 100644
index 0000000000..6e5145c61d
--- /dev/null
+++ b/libraries/python-transaction/python-transaction.info
@@ -0,0 +1,10 @@
+PRGNAM="python-transaction"
+VERSION="1.0.0"
+HOMEPAGE="http://pypi.python.org/pypi/transaction/1.0.0"
+DOWNLOAD="http://pypi.python.org/packages/source/t/transaction/transaction-1.0.0.tar.gz"
+MD5SUM="10b5d02dcded26f6f265771e6d68fc06"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
+APPROVED="dsomero"
diff --git a/libraries/python-transaction/slack-desc b/libraries/python-transaction/slack-desc
new file mode 100644
index 0000000000..1621c3eab2
--- /dev/null
+++ b/libraries/python-transaction/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-transaction: python-transaction (Python Transaction Management)
+python-transaction:
+python-transaction: This is a generic transaction implementation for Python. It
+python-transaction: is mainly used by the ZODB. Note that the data manager API,
+python-transaction: transaction.interfaces.IDataManager, is syntactically simple, but
+python-transaction: semantically complex. The semantics were not easy to express in the
+python-transaction: interface. The semantics are presented in detail through examples
+python-transaction: of a sample data manager in transaction.tests.test_SampleDataManager.
+python-transaction:
+python-transaction:
+python-transaction: Homepage: http://pypi.python.org/pypi/transaction/1.0.0