summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Alexander Verbovetsky <alik@ejik.org>2021-01-29 01:32:54 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-01-30 10:29:14 +0700
commit8183a67a2414e0746b47d4b4d43c246c8bd804bb (patch)
tree8676c20a492c5f7bc01c51651f0e3d2c1f636b24 /libraries
parent59ee771597582c667b66157d82f7d6c9e6635b52 (diff)
downloadslackbuilds-8183a67a2414e0746b47d4b4d43c246c8bd804bb.tar.gz
slackbuilds-8183a67a2414e0746b47d4b4d43c246c8bd804bb.tar.xz
libraries/python-ruamel.yaml: Add optional python3 support.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python-ruamel.yaml/README2
-rw-r--r--libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/libraries/python-ruamel.yaml/README b/libraries/python-ruamel.yaml/README
index 28dd43dc00..91a1a82256 100644
--- a/libraries/python-ruamel.yaml/README
+++ b/libraries/python-ruamel.yaml/README
@@ -13,3 +13,5 @@ that preserves, among others:
* flow style sequences ( ‘a: b, c, d’)
* anchor names that are hand-crafted (i.e. not of the form``idNNN``)
* merges in dictionaries are preserved
+
+Python3 is an optional dependency (autodetected).
diff --git a/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
index 17b1b8ee01..9eb2692772 100644
--- a/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
+++ b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-ruamel.yaml
-# Copyright 2019, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2019-2021, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-ruamel.yaml
VERSION=${VERSION:-0.16.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -58,6 +58,10 @@ find -L . \
RUAMEL_NO_PIP_INSTALL_CHECK=1 python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ RUAMEL_NO_PIP_INSTALL_CHECK=1 python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true