summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Lionel Young <redtricycle@gmail.com>2011-03-05 18:48:56 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2011-03-05 18:48:56 -0300
commitba84558aea018023be37f62908e44852063e0bad (patch)
treec370b85f872443bb3f071faa18ac55f98ec91cf7 /libraries
parentbec82caba55fdf2e2d986320cbbe15c3b8ca2ed8 (diff)
downloadslackbuilds-ba84558aea018023be37f62908e44852063e0bad.tar.gz
slackbuilds-ba84558aea018023be37f62908e44852063e0bad.tar.xz
libraries/python-openid: Added (python openid library)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python-openid/README1
-rw-r--r--libraries/python-openid/python-openid.SlackBuild71
-rw-r--r--libraries/python-openid/python-openid.info10
-rw-r--r--libraries/python-openid/slack-desc19
4 files changed, 101 insertions, 0 deletions
diff --git a/libraries/python-openid/README b/libraries/python-openid/README
new file mode 100644
index 0000000000..a88bb6bf31
--- /dev/null
+++ b/libraries/python-openid/README
@@ -0,0 +1 @@
+Python OpenID library.
diff --git a/libraries/python-openid/python-openid.SlackBuild b/libraries/python-openid/python-openid.SlackBuild
new file mode 100644
index 0000000000..01ab455291
--- /dev/null
+++ b/libraries/python-openid/python-openid.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2009 Eric Hameleers <alien@slackware.com>, Eindhoven, Netherlands
+
+# Slackware build script for python-openid
+
+# Written by Lionel Young <redtricycle@gmail.com>
+
+PRGNAM=python-openid
+SRCNAM=openid-python-openid
+SRCNAMSUF=b666238
+VERSION=${VERSION:-2.2.5}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION-0-g$SRCNAMSUF.tar.gz
+cd $SRCNAM-$SRCNAMSUF
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES-2.2.0 LICENSE README NOTICE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-openid/python-openid.info b/libraries/python-openid/python-openid.info
new file mode 100644
index 0000000000..b2fb745b5b
--- /dev/null
+++ b/libraries/python-openid/python-openid.info
@@ -0,0 +1,10 @@
+PRGNAM="python-openid"
+VERSION="2.2.5"
+HOMEPAGE="https://github.com/openid/python-openid"
+DOWNLOAD="https://download.github.com/openid-python-openid-2.2.5-0-gb666238.tar.gz"
+MD5SUM="7bb24dc6abd941ebff6a83c1ac7e4370"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
+APPROVED="Niels Horn"
diff --git a/libraries/python-openid/slack-desc b/libraries/python-openid/slack-desc
new file mode 100644
index 0000000000..b1ffe78921
--- /dev/null
+++ b/libraries/python-openid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-openid: python-openid (python openid library)
+python-openid:
+python-openid: Python OpenID library.
+python-openid:
+python-openid: Home: https://github.com/openid/python-openid
+python-openid:
+python-openid:
+python-openid:
+python-openid:
+python-openid:
+python-openid: