summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Javier Rojas <jerojasro@gmail.com>2010-05-11 20:00:59 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:59 +0200
commitd56ff137a7626634d00465061264d6fcf4049a0d (patch)
tree7583defc9afde0eb252ee7003dc4d6bf4c387d71 /libraries
parent9613402a98a1b0c9f324a2bc58ea2792b201d5d0 (diff)
downloadslackbuilds-d56ff137a7626634d00465061264d6fcf4049a0d.tar.gz
slackbuilds-d56ff137a7626634d00465061264d6fcf4049a0d.tar.xz
libraries/pexpect: Added to 12.0 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pexpect/README4
-rw-r--r--libraries/pexpect/pexpect.SlackBuild66
-rw-r--r--libraries/pexpect/pexpect.info8
-rw-r--r--libraries/pexpect/slack-desc19
4 files changed, 97 insertions, 0 deletions
diff --git a/libraries/pexpect/README b/libraries/pexpect/README
new file mode 100644
index 0000000000..1d15e556c1
--- /dev/null
+++ b/libraries/pexpect/README
@@ -0,0 +1,4 @@
+Pexpect is a Python module for spawning child applications; controlling them;
+and responding to expected patterns in their output. Pexpect can be used for
+automating interactive applications such as ssh, ftp, passwd, telnet, etc.
+Pexpect is pure Python.
diff --git a/libraries/pexpect/pexpect.SlackBuild b/libraries/pexpect/pexpect.SlackBuild
new file mode 100644
index 0000000000..accf04524c
--- /dev/null
+++ b/libraries/pexpect/pexpect.SlackBuild
@@ -0,0 +1,66 @@
+#!/bin/sh
+
+# Slackware build script for Pexpect
+
+# Copyright (c) 2007 Javier Rojas <jerojasro@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Exit on most errors
+set -e
+
+PRGNAM=pexpect
+VERSION=2.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+python setup.py bdist
+
+tar xvzf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a -r INSTALL LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pexpect/pexpect.info b/libraries/pexpect/pexpect.info
new file mode 100644
index 0000000000..5a96d71fce
--- /dev/null
+++ b/libraries/pexpect/pexpect.info
@@ -0,0 +1,8 @@
+PRGNAM="pexpect"
+VERSION="2.1"
+HOMEPAGE="http://pexpect.sourceforge.net/"
+DOWNLOAD="http://dl.sourceforge.net/pexpect/pexpect-2.1.tar.gz"
+MD5SUM="fd3d67ac085332f074cd665424dcd631"
+MAINTAINER="Javier Rojas"
+EMAIL="jerojasro@gmail.com"
+APPROVED="rworkman"
diff --git a/libraries/pexpect/slack-desc b/libraries/pexpect/slack-desc
new file mode 100644
index 0000000000..2852489912
--- /dev/null
+++ b/libraries/pexpect/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pexpect: pexpect (Python module for spawning child applications)
+pexpect:
+pexpect: Pexpect is a Python module for spawning child applications,
+pexpect: controlling them, and responding to expected patterns in their
+pexpect: output. Pexpect can be used for automating interactive
+pexpect: applications such as ssh, ftp, passwd, telnet, etc.
+pexpect: Pexpect is pure Python.
+pexpect:
+pexpect:
+pexpect:
+pexpect: