summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Ryan Losh <od2010@sbcglobal.net>2016-09-23 20:18:55 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-23 20:18:55 +0700
commite2a06c20d1410d1fa80e6979f40f25beb69a3639 (patch)
tree128626250bb663bf2e1f47b8e60792f317047cbc /libraries
parent521077fa9b8ac68d7d98d12261a8bdbeb0e06cc6 (diff)
downloadslackbuilds-e2a06c20d1410d1fa80e6979f40f25beb69a3639.tar.gz
slackbuilds-e2a06c20d1410d1fa80e6979f40f25beb69a3639.tar.xz
libraries/python3-dvdvideo: Added (Video DVD reader library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python3-dvdvideo/README9
-rw-r--r--libraries/python3-dvdvideo/python3-dvdvideo.SlackBuild97
-rw-r--r--libraries/python3-dvdvideo/python3-dvdvideo.info10
-rw-r--r--libraries/python3-dvdvideo/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/libraries/python3-dvdvideo/README b/libraries/python3-dvdvideo/README
new file mode 100644
index 0000000000..a14051e238
--- /dev/null
+++ b/libraries/python3-dvdvideo/README
@@ -0,0 +1,9 @@
+This library reads and parses video DVD. It includes a UDF parser
+and video DVD structure parses. It supports unencrypted disks and
+also encrypted ones using the external libdvdcss.
+
+A tool (dvdvideo-backup-image) is provided to make decrypted copies
+of disks. This disks often contain various defects in the data
+structures to complicate reading them.
+
+libdvdcss is an optional dependency.
diff --git a/libraries/python3-dvdvideo/python3-dvdvideo.SlackBuild b/libraries/python3-dvdvideo/python3-dvdvideo.SlackBuild
new file mode 100644
index 0000000000..45ac987170
--- /dev/null
+++ b/libraries/python3-dvdvideo/python3-dvdvideo.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/sh
+
+# Slackware build script for python3-dvdvideo
+
+# Copyright 2016 Ryan Losh, author of this Slackware build script only.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+#
+# python-dvdvideo software released under GPL version 3 or later.
+# Author: Bastian Blank
+# Software Announcement: http://bblank.thinkmo.de/blog/new-software-python-dvdvideo
+# Git repository: git://anonscm.debian.org/users/waldi/python-dvdvideo.git
+# Git repository: https://anonscm.debian.org/git/users/waldi/python-dvdvideo.git
+#
+
+# |-----------------------------------------------------------------| #
+
+PRGNAM=python3-dvdvideo
+VERSION=${VERSION:-0.20140413}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+rm -rf python-dvdvideo-$VERSION
+tar xvf $CWD/$VERSION.tar.gz
+mv python-dvdvideo-$VERSION $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog debian/control debian/copyright COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python3-dvdvideo/python3-dvdvideo.info b/libraries/python3-dvdvideo/python3-dvdvideo.info
new file mode 100644
index 0000000000..a10c71b27a
--- /dev/null
+++ b/libraries/python3-dvdvideo/python3-dvdvideo.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-dvdvideo"
+VERSION="0.20140413"
+HOMEPAGE="https://anonscm.debian.org/cgit/users/waldi/python-dvdvideo.git/"
+DOWNLOAD="https://github.com/jgirot/python-dvdvideo/archive/0.20140413.tar.gz"
+MD5SUM="473e7d1aaeeb55621d35dda2ebd81476"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Ryan Losh"
+EMAIL="od2010@sbcglobal.net"
diff --git a/libraries/python3-dvdvideo/slack-desc b/libraries/python3-dvdvideo/slack-desc
new file mode 100644
index 0000000000..ec65e07dc3
--- /dev/null
+++ b/libraries/python3-dvdvideo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-dvdvideo: python3-dvdvideo (Video DVD reader library)
+python3-dvdvideo:
+python3-dvdvideo: This library reads and parses video DVD. It includes a UDF parser
+python3-dvdvideo: and video DVD structure parses. It supports unencrypted disks and
+python3-dvdvideo: also encrypted ones using the external libdvdcss.
+python3-dvdvideo:
+python3-dvdvideo: A tool (dvdvideo-backup-image) is provided to make decrypted copies
+python3-dvdvideo: of disks. This disks often contain various defects in the data
+python3-dvdvideo: structures to complicate reading them.
+python3-dvdvideo:
+python3-dvdvideo: