summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Michales Michaloudes <korgie@gmail.com>2010-05-13 00:59:40 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:59:40 +0200
commita91767088d7b2bd40e16f7fc9fd207906f33599a (patch)
tree19b7b093cccc30a0641c5baadf6322b3a28caccd /multimedia
parent1411aea895650bcda8a1e6c228a9bd0c4f33b8db (diff)
downloadslackbuilds-a91767088d7b2bd40e16f7fc9fd207906f33599a.tar.gz
slackbuilds-a91767088d7b2bd40e16f7fc9fd207906f33599a.tar.xz
multimedia/gigedit: Added to 13.0 repository
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gigedit/README5
-rw-r--r--multimedia/gigedit/gigedit.SlackBuild77
-rw-r--r--multimedia/gigedit/gigedit.info10
-rw-r--r--multimedia/gigedit/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/multimedia/gigedit/README b/multimedia/gigedit/README
new file mode 100644
index 0000000000..dbc084191e
--- /dev/null
+++ b/multimedia/gigedit/README
@@ -0,0 +1,5 @@
+Gigedit is an instrument editor for gig files. Gig files are
+used by software samplers such as LinuxSampler and GigaStudio.
+
+This requires gtkmm and libgig.
+liblscp and linuxsampler are optional dependencies.
diff --git a/multimedia/gigedit/gigedit.SlackBuild b/multimedia/gigedit/gigedit.SlackBuild
new file mode 100644
index 0000000000..bf666cbc91
--- /dev/null
+++ b/multimedia/gigedit/gigedit.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for <gigedit>
+# Written by Michales Michaloudes korgie@gmail.com
+
+PRGNAM=gigedit
+VERSION=${VERSION:-0.2.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+# doc/quickstart/Makefile has docdir hardcoded to /usr/share/doc/gigedit
+make docdir=/usr/doc/$PRGNAM-$VERSION
+make docdir=/usr/doc/$PRGNAM-$VERSION install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING ChangeLog INSTALL NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/gigedit/gigedit.info b/multimedia/gigedit/gigedit.info
new file mode 100644
index 0000000000..e28bd051ed
--- /dev/null
+++ b/multimedia/gigedit/gigedit.info
@@ -0,0 +1,10 @@
+PRGNAM="gigedit"
+VERSION="0.2.0"
+HOMEPAGE="http://www.linuxsampler.org"
+DOWNLOAD="http://download.linuxsampler.org/packages/gigedit-0.2.0.tar.gz"
+MD5SUM="eadfc82118460206e8f83c104f9d2a3a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Michales Michaloudes"
+EMAIL="korgie@gmail.com"
+APPROVED="rworkman"
diff --git a/multimedia/gigedit/slack-desc b/multimedia/gigedit/slack-desc
new file mode 100644
index 0000000000..662b536717
--- /dev/null
+++ b/multimedia/gigedit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+gigedit: gigedi (instrument editor for gig files)
+gigedit:
+gigedit: gigedit allows you to edit and create instruments for the Gigasampler
+gigedit: format, which can be used with LinuxSampler as well as with Tascam's
+gigedit: Gigastudio. Following our line of modularity we also made the
+gigedit: instrument editors independent applications.
+gigedit:
+gigedit:
+gigedit:
+gigedit:
+gigedit: