summaryrefslogtreecommitdiffstats
path: root/network/luakit
diff options
context:
space:
mode:
author Marek Srejma <sam_web@yahoo.de>2018-07-01 08:58:15 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-07-07 06:54:12 +0700
commit9c2492cfe117c8eff00e12fd6cba5b4743e204f1 (patch)
treee1772eb868484cff6ab471aa09b52b4fc793dd2f /network/luakit
parent4b319ef27bcafcf19fbe3bf6b57f9f0ba6475af8 (diff)
downloadslackbuilds-9c2492cfe117c8eff00e12fd6cba5b4743e204f1.tar.gz
slackbuilds-9c2492cfe117c8eff00e12fd6cba5b4743e204f1.tar.xz
network/luakit: Updated for version 2.0 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/luakit')
-rw-r--r--network/luakit/README8
-rw-r--r--network/luakit/luakit.SlackBuild30
-rw-r--r--network/luakit/luakit.info12
3 files changed, 33 insertions, 17 deletions
diff --git a/network/luakit/README b/network/luakit/README
index 88fe51204b..86798e4dea 100644
--- a/network/luakit/README
+++ b/network/luakit/README
@@ -7,3 +7,11 @@ constructed by the config files present in /etc/xdg/luakit
Just copy the files you wish to change (and the rc.lua) into
$XDG_CONFIG_HOME/luakit (defaults to ~/.config/luakit) and
luakit will use those files when you next launch it.
+
+The luajit package is an optional dependency.
+
+To enable building luakit with luajit support, use
+ LUAJIT=1
+
+To enable clang instead of gcc as the compiler, use
+ CC=clang
diff --git a/network/luakit/luakit.SlackBuild b/network/luakit/luakit.SlackBuild
index 8d9eac6c93..a3808aa5e9 100644
--- a/network/luakit/luakit.SlackBuild
+++ b/network/luakit/luakit.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for luakit
# Copyright 2013, Andrew Tkalia <anddt@yandex.ru>, Ukraine, Kyiv
+# Update 2018-06-30 by Marek Srejma <sam_web@yahoo.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,9 +24,11 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=luakit
-VERSION=${VERSION:-2017.08.10}
+VERSION=${VERSION:-2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+LUAJIT=${LUAJIT:-0} # 0 or 1
+CC=${CC:-cc} # cc, gcc or clang
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,10 +43,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+if egrep -qo "^i[2-6]86$" <<<"$ARCH"; then
+ SLKCFLAGS="-O2 -march=$ARCH -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
else
@@ -55,9 +56,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf $PRGNAM-debian-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+cd $PRGNAM-debian-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -65,18 +66,25 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+_CFLAGS=`grep CFLAGS config.mk | sed -e "s/CFLAGS\s*+=//g" | tr "\n" " "`
make \
PREFIX=/usr \
MANPREFIX=/usr/man \
- DOCDIR=/usr/doc/luakit-$VERSION \
- DEVELOPMENT_PATHS=0
+ DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ DEVELOPMENT_PATHS=0 \
+ CFLAGS="$_CFLAGS $SLKCFLAGS" \
+ LUA_BIN_NAME=lua \
+ LUA_PKG_NAME=lua \
+ USE_LUAJIT=$LUAJIT \
+ CC=$CC
make install \
DESTDIR=$PKG \
PREFIX=/usr \
MANPREFIX=$PKG/usr/man \
- DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
-
+ DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION \
+ LUA_BIN_NAME=lua \
+ LUA_PKG_NAME=lua
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/network/luakit/luakit.info b/network/luakit/luakit.info
index a82d2de3cf..464d4d1679 100644
--- a/network/luakit/luakit.info
+++ b/network/luakit/luakit.info
@@ -1,10 +1,10 @@
PRGNAM="luakit"
-VERSION="2017.08.10"
+VERSION="2.0"
HOMEPAGE="https://github.com/luakit/luakit"
-DOWNLOAD="https://github.com/luakit/luakit/archive/2017.08.10/luakit-2017.08.10.tar.gz"
-MD5SUM="77065e5acf7a941954d6c61a28df98d1"
+DOWNLOAD="https://github.com/luakit/luakit/archive/debian/2.0/luakit-2.0.tar.gz"
+MD5SUM="2f5ab83a7835db482220b2279351e23c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="luajit webkit2gtk lua-filesystem"
-MAINTAINER="Leonard Schmidt"
-EMAIL="lems@gmx.net"
+REQUIRES="webkit2gtk lua-filesystem"
+MAINTAINER="Marek Srejma"
+EMAIL="sam_web@yahoo.de"