summaryrefslogtreecommitdiffstats
path: root/network/periscope
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-05-13 01:00:11 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 01:00:11 +0200
commit176cf239c14515d54fb88a7822c1f2ef29564067 (patch)
treeb563a8c50bd34795c33c48350bc9169ca226d0c3 /network/periscope
parentc910da288b3bfcfd11f263df747e89c2e3b6348e (diff)
downloadslackbuilds-176cf239c14515d54fb88a7822c1f2ef29564067.tar.gz
slackbuilds-176cf239c14515d54fb88a7822c1f2ef29564067.tar.xz
network/periscope: Added to 13.0 repository
Diffstat (limited to 'network/periscope')
-rw-r--r--network/periscope/README10
-rw-r--r--network/periscope/periscope.SlackBuild71
-rw-r--r--network/periscope/periscope.info10
-rw-r--r--network/periscope/slack-desc19
4 files changed, 110 insertions, 0 deletions
diff --git a/network/periscope/README b/network/periscope/README
new file mode 100644
index 0000000000..dbe7af7b00
--- /dev/null
+++ b/network/periscope/README
@@ -0,0 +1,10 @@
+Periscope is a subtitles searching module written in python that tries to find
+a correct match for a given video file. The subtitles sites are handled as
+plugins and currently support OpenSubtitles, SubtitleSource, Podnapisi,
+Subscene and Subtitulos.
+
+A python/nautilus integration script is copied to the doc directory.
+
+The program requires pysetuptools for building and BeautifulSoup to run. A rar
+unpacker is recommended but can be avoided if you disable the plugins for
+subtitles sites using this format.
diff --git a/network/periscope/periscope.SlackBuild b/network/periscope/periscope.SlackBuild
new file mode 100644
index 0000000000..d52fc1cd35
--- /dev/null
+++ b/network/periscope/periscope.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for periscope.
+
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=periscope
+VERSION=0.1.7.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="bin/periscope-nautilus/periscope-nautilus.py"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/periscope/periscope.info b/network/periscope/periscope.info
new file mode 100644
index 0000000000..95e944c75d
--- /dev/null
+++ b/network/periscope/periscope.info
@@ -0,0 +1,10 @@
+PRGNAM="periscope"
+VERSION="0.1.7.1"
+HOMEPAGE="http://code.google.com/p/periscope/"
+DOWNLOAD="http://slackbuilds.org/sources/13.0/periscope-0.1.7.1.tar.bz2"
+MD5SUM="32ad8474976035b950f017a65f17350e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/network/periscope/slack-desc b/network/periscope/slack-desc
new file mode 100644
index 0000000000..4812ccfe0c
--- /dev/null
+++ b/network/periscope/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+periscope: periscope (Python subtitles searching module)
+periscope:
+periscope: Periscope is a subtitles searching module written in python that tries
+periscope: to find a correct match for a given video file. The subtitles sites
+periscope: are handled as plugins and currently support OpenSubtitles,
+periscope: SubtitleSource, Podnapisi, Subscene and Subtitulos.
+periscope:
+periscope:
+periscope:
+periscope:
+periscope: