summaryrefslogtreecommitdiffstats
path: root/network/spambayes
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2010-08-28 14:44:51 -0400
committer Erik Hanson <erik@slackbuilds.org>2010-08-29 15:32:15 -0500
commit681a94659de0771ebae1aa2cf61f4a33fb1307be (patch)
treeec4499e258fee15658c2af31157416e5cbe2cd53 /network/spambayes
parent728d8f1a341276cccebd4cbf3e5f1de5c5678165 (diff)
downloadslackbuilds-681a94659de0771ebae1aa2cf61f4a33fb1307be.tar.gz
slackbuilds-681a94659de0771ebae1aa2cf61f4a33fb1307be.tar.xz
network/spambayes: Miscellaneous cleanups and moved from system.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'network/spambayes')
-rw-r--r--network/spambayes/README6
-rw-r--r--network/spambayes/slack-desc19
-rw-r--r--network/spambayes/spambayes.SlackBuild50
-rw-r--r--network/spambayes/spambayes.info10
4 files changed, 85 insertions, 0 deletions
diff --git a/network/spambayes/README b/network/spambayes/README
new file mode 100644
index 0000000000..179ca058b7
--- /dev/null
+++ b/network/spambayes/README
@@ -0,0 +1,6 @@
+SpamBayes uses a different set of algorithm to most statistical spam filters,
+which enables to dramatically lower the number of legitimate mail classified as
+spam, through the introduction of an 'unsure' category.
+
+SpamBayes can be used as a POP3 or an IMAP proxy, as well as a simple mail
+filter for use with procmail.
diff --git a/network/spambayes/slack-desc b/network/spambayes/slack-desc
new file mode 100644
index 0000000000..7d1061511c
--- /dev/null
+++ b/network/spambayes/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+spambayes: spambayes (Python-based spam filter using statistical analysis)
+spambayes:
+spambayes: SpamBayes uses a different set of algorithm to most statistical spam
+spambayes: filters, which enables to dramatically lower the number of
+spambayes: legitimate mail classified as spam, through the introduction of an
+spambayes: 'unsure' category.
+spambayes:
+spambayes: SpamBayes can be used as a POP3 or an IMAP proxy, as well as a
+spambayes: simple mail filter for use with procmail.
+spambayes:
+spambayes: Homepage: http://spambayes.sourceforge.net/
diff --git a/network/spambayes/spambayes.SlackBuild b/network/spambayes/spambayes.SlackBuild
new file mode 100644
index 0000000000..6bc66d1028
--- /dev/null
+++ b/network/spambayes/spambayes.SlackBuild
@@ -0,0 +1,50 @@
+#!/bin/sh
+
+# Slackware build script for spambayes
+# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+PRGNAM=spambayes
+VERSION=${VERSION:-1.0.4}
+BUILD=${BUILD:-3}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+rw,go+r-w,a-sx+X .
+
+# Suppress sets module deprecation warning in Python 2.6+.
+sed -i 's/from sets import Set/Set = set/' \
+ spambayes/{classifier,TestDriver,tokenizer,ProxyUI}.py
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a contrib $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/spambayes/spambayes.info b/network/spambayes/spambayes.info
new file mode 100644
index 0000000000..2ea6c31a92
--- /dev/null
+++ b/network/spambayes/spambayes.info
@@ -0,0 +1,10 @@
+PRGNAM="spambayes"
+VERSION="1.0.4"
+HOMEPAGE="http://spambayes.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/spambayes/spambayes-1.0.4.tar.gz"
+MD5SUM="78c33e79888d410711ff3c7dd7e98d79"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
+APPROVED="dsomero"