summaryrefslogtreecommitdiffstats
path: root/network/turbolift
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-02-12 18:01:58 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-02-12 21:10:36 +0700
commit75335b6ce08bab4a45eb0ab9e785b45756518584 (patch)
treed51d13b5da77f4061d43b3eeee0d40c6ba911cdf /network/turbolift
parent68328c12d45d5dcc1b2ffc9cdc9d8078f15b8784 (diff)
downloadslackbuilds-75335b6ce08bab4a45eb0ab9e785b45756518584.tar.gz
slackbuilds-75335b6ce08bab4a45eb0ab9e785b45756518584.tar.xz
network/turbolift: Added (OpenStack Swift Uploader).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/turbolift')
-rw-r--r--network/turbolift/README7
-rw-r--r--network/turbolift/slack-desc19
-rw-r--r--network/turbolift/turbolift.SlackBuild85
-rw-r--r--network/turbolift/turbolift.info10
4 files changed, 121 insertions, 0 deletions
diff --git a/network/turbolift/README b/network/turbolift/README
new file mode 100644
index 0000000000..9e9bb2247a
--- /dev/null
+++ b/network/turbolift/README
@@ -0,0 +1,7 @@
+OpenStack Swift -Cloud Files- Uploader.
+
+If you have found yourself in a situation where you needed or wanted to upload
+a whole bunch of files to Cloud Files quickly, this is what you are looking for.
+
+Turbolift is an assistant for uploading files to the the Rackspace Cloud Files
+Repository with a bunch of options.
diff --git a/network/turbolift/slack-desc b/network/turbolift/slack-desc
new file mode 100644
index 0000000000..06da0a7ea9
--- /dev/null
+++ b/network/turbolift/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+turbolift: turbolift (OpenStack Swift -Cloud Files- Uploader)
+turbolift:
+turbolift: If you have found yourself in a situation where you needed or
+turbolift: wanted to upload a whole bunch of files to Cloud Files quickly,
+turbolift: this is what you are looking for.
+turbolift:
+turbolift: Homepage: https://github.com/cloudnull/turbolift
+turbolift:
+turbolift:
+turbolift:
+turbolift:
diff --git a/network/turbolift/turbolift.SlackBuild b/network/turbolift/turbolift.SlackBuild
new file mode 100644
index 0000000000..2752f2caed
--- /dev/null
+++ b/network/turbolift/turbolift.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for turbolift
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=turbolift
+VERSION=${VERSION:-2.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/turbolift/turbolift.info b/network/turbolift/turbolift.info
new file mode 100644
index 0000000000..45ed57f035
--- /dev/null
+++ b/network/turbolift/turbolift.info
@@ -0,0 +1,10 @@
+PRGNAM="turbolift"
+VERSION="2.0.4"
+HOMEPAGE="https://github.com/cloudnull/turbolift"
+DOWNLOAD="https://github.com/cloudnull/turbolift/archive/v2.0.4.tar.gz"
+MD5SUM="976238dd102ff2459b85b91a201de522"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-requests PrettyTable"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"