summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2013-11-16 22:41:16 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-11-21 23:56:23 -0600
commit1526d9fa36c41dff61c5ea4175436d5bf24b5974 (patch)
tree5ba6da6ea84c23048e8a3ae192573a0245599fd1 /network
parent57e08a4fc0790ef1584e5114ad013c2482a53e6a (diff)
downloadslackbuilds-1526d9fa36c41dff61c5ea4175436d5bf24b5974.tar.gz
slackbuilds-1526d9fa36c41dff61c5ea4175436d5bf24b5974.tar.xz
network/qutim: Removed (painful to maintain).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/qutim/README4
-rw-r--r--network/qutim/doinst.sh9
-rw-r--r--network/qutim/qutim.SlackBuild123
-rw-r--r--network/qutim/qutim.info10
-rw-r--r--network/qutim/slack-desc19
5 files changed, 0 insertions, 165 deletions
diff --git a/network/qutim/README b/network/qutim/README
deleted file mode 100644
index 852f474bc8..0000000000
--- a/network/qutim/README
+++ /dev/null
@@ -1,4 +0,0 @@
-qutim (qt instant messenger)
-
-qutIM is free and open-source multiprotocol (ICQ, Jabber, Mail.Ru,
-IRC, VKontakte) instant messenger.
diff --git a/network/qutim/doinst.sh b/network/qutim/doinst.sh
deleted file mode 100644
index 3e5691a052..0000000000
--- a/network/qutim/doinst.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/network/qutim/qutim.SlackBuild b/network/qutim/qutim.SlackBuild
deleted file mode 100644
index 7867b7b363..0000000000
--- a/network/qutim/qutim.SlackBuild
+++ /dev/null
@@ -1,123 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for qutim
-# Copyright by Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy 2012
-# Based on slackbuilds.org perl template.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=qutim
-VERSION=${VERSION:-20120728_c85176a}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-DOCS="AUTHORS CCBYSA COPYING GPL README.mediawiki"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# detailed cmake options are from archlinux
-# https://aur.archlinux.org/packages/qu/qutim-git/PKGBUILD
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DMAN_INSTALL_DIR=/usr/man \
- -DQRCICONS=0 \
- -DQMLCHAT:BOOL=0 \
- -DKINETICPOPUPS:BOOL=0 \
- -DASTRAL:BOOL=0 \
- -DVKONTAKTE:BOOL=0 \
- -DPLUGMAN:BOOL=0 \
- -DSCRIPTAPI:BOOL=0 \
- -DSTACKEDCHATFORM:BOOL=0 \
- -DMOBILEABOUT:BOOL=0 \
- -DKINETICSCROLLER:BOOL=0 \
- -DWEBKITSTYLE/MAEMO:BOOL=0 \
- -DMOBILECONTACTINFO:BOOL=0 \
- -DMOBILESETTINGSDIALOG:BOOL=0 \
- -DDECLARATIVE_UI:BOOL=0 \
- -DSYMBIANINTEGRATION:BOOL=0 \
- -DMACINTEGRATION:BOOL=0 \
- -DMAEMO5INTEGRATION:BOOL=0 \
- -DMEEGOINTEGRATION:BOOL=0 \
- -DMULTIMEDIABACKEND:BOOL=0 \
- -DANTIBOSS:BOOL=0 \
- -DWININTEGRATION:BOOL=0 \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir $PKG/usr/doc
-mv $PKG/usr/share/$PRGNAM/doc $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/qutim/qutim.info b/network/qutim/qutim.info
deleted file mode 100644
index f58ed6da6b..0000000000
--- a/network/qutim/qutim.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="qutim"
-VERSION="20120728_c85176a"
-HOMEPAGE="http://qutim.org/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/qutim-20120728_c85176a.tar.xz"
-MD5SUM="46c4a72b54a504babc6fbb964dd55980"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"
diff --git a/network/qutim/slack-desc b/network/qutim/slack-desc
deleted file mode 100644
index 73620dc222..0000000000
--- a/network/qutim/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-qutim: qutim (qt instant messenger)
-qutim:
-qutim: qutIM is free and open-source multiprotocol (ICQ, Jabber, Mail.Ru,
-qutim: IRC, VKontakte) instant messenger.
-qutim:
-qutim: homepage: http://qutim.org/
-qutim:
-qutim:
-qutim:
-qutim:
-qutim: