summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2012-09-07 10:04:17 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-08 17:28:30 -0500
commitabfb7d1c915bd5f9eaea843051804df3e5a4bbf1 (patch)
treec0fec5ed9c6b38837c9573250384c1a7ec3603ba /network
parent68fa0da7c26f2d255a84692ec8e50e77951bf231 (diff)
downloadslackbuilds-abfb7d1c915bd5f9eaea843051804df3e5a4bbf1.tar.gz
slackbuilds-abfb7d1c915bd5f9eaea843051804df3e5a4bbf1.tar.xz
network/ettercap: Added (new official ettercap).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/ettercap/README11
-rw-r--r--network/ettercap/doinst.sh19
-rw-r--r--network/ettercap/ettercap.SlackBuild109
-rw-r--r--network/ettercap/ettercap.desktop7
-rw-r--r--network/ettercap/ettercap.info10
-rw-r--r--network/ettercap/slack-desc18
6 files changed, 174 insertions, 0 deletions
diff --git a/network/ettercap/README b/network/ettercap/README
new file mode 100644
index 0000000000..d5416e6943
--- /dev/null
+++ b/network/ettercap/README
@@ -0,0 +1,11 @@
+Ettercap is a suite for man in the middle attacks on LAN. It features
+sniffing of live connections, content filtering on the fly and many other
+interesting tricks. It is capable of intercepting traffic on a network
+segment, capturing passwords, and conducting man-in-the-middle attacks
+against a number of common protocols.
+
+It supports active and passive dissection of many protocols (even
+ciphered ones) and includes many feature for network and host analysis.
+
+It is free software, licensed under the terms of the
+GNU General Public License.
diff --git a/network/ettercap/doinst.sh b/network/ettercap/doinst.sh
new file mode 100644
index 0000000000..837a7c8f69
--- /dev/null
+++ b/network/ettercap/doinst.sh
@@ -0,0 +1,19 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD|md5sum)" = "$(cat $NEW|md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/etter.conf.new
+
+if [ -x usr/bin/update-desktop-database ]; then
+ usr/bin/update-desktop-database -q usr/share/applications
+fi
+
diff --git a/network/ettercap/ettercap.SlackBuild b/network/ettercap/ettercap.SlackBuild
new file mode 100644
index 0000000000..34a8728aa4
--- /dev/null
+++ b/network/ettercap/ettercap.SlackBuild
@@ -0,0 +1,109 @@
+#!/bin/sh
+
+# Slackbuild for ettercap
+# forked off ettercap-NG.SlackBuild by Matteo Bernardini <ponce@slackbuilds.org>
+#
+# Copyright 2008 meckafett <tom[DOT]bradish[AT]gmail[DOT]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ettercap
+VERSION=${VERSION:-0.7.4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM
+chown -R root:root .
+chmod -R u+w,go+r,a-s .
+
+sed -i "s|-O2 -funroll-loops|$SLKCFLAGS -funroll-loops|" configure.in
+
+sh autogen.sh
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib$LIBDIRSUFFIX \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-plugins \
+ --enable-gtk \
+ --disable-debug \
+ --build=$ARCH-slackware-linux \
+
+make
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/share/applications
+cat $CWD/ettercap.desktop > $PKG/usr/share/applications/ettercap.desktop
+
+mv $PKG/etc/etter.conf $PKG/etc/etter.conf.new
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG INSTALL LICENSE README* THANKS TODO* doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/ettercap/ettercap.desktop b/network/ettercap/ettercap.desktop
new file mode 100644
index 0000000000..5ca2e8b4d1
--- /dev/null
+++ b/network/ettercap/ettercap.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Ettercap GTK
+Icon=/usr/share/ettercap/ettercap.png
+Exec=/usr/bin/ettercap --gtk
+Terminal=false
+Type=Application
+Categories=Network;System;Security;GTK;
diff --git a/network/ettercap/ettercap.info b/network/ettercap/ettercap.info
new file mode 100644
index 0000000000..e79df77f2e
--- /dev/null
+++ b/network/ettercap/ettercap.info
@@ -0,0 +1,10 @@
+PRGNAM="ettercap"
+VERSION="0.7.4.1"
+HOMEPAGE="http://ettercap.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/ettercap/ettercap-0.7.4.1.tar.gz"
+MD5SUM="8e13ff5504b5bb4f1fc6a465d57ce7ea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libnet"
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/network/ettercap/slack-desc b/network/ettercap/slack-desc
new file mode 100644
index 0000000000..0ba8403701
--- /dev/null
+++ b/network/ettercap/slack-desc
@@ -0,0 +1,18 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+ |-----handy-ruler------------------------------------------------------|
+ettercap: ettercap (Multipurpose sniffer/interceptor/logger)
+ettercap:
+ettercap: Ettercap is a suite for man in the middle attacks on LAN. It
+ettercap: features sniffing of live connections, content filtering on the
+ettercap: fly and many other interesting tricks. It supports active and
+ettercap: passive dissection of many protocols (even ciphered ones) and
+ettercap: includes many feature for network and host host analysis.
+ettercap:
+ettercap: Homepage: http://ettercap.sourceforge.net/
+ettercap:
+ettercap: