summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Niels Horn <niels.horn@gmail.com>2010-05-13 00:39:08 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:39:08 +0200
commit14330a180d0c0c63053da6259ed95eac52b92910 (patch)
tree3b9edcc03f5203ef964fb745be0753f3b178a920 /office
parent1f653e4318842e92b34046f949404362fe3e6f1f (diff)
downloadslackbuilds-14330a180d0c0c63053da6259ed95eac52b92910.tar.gz
slackbuilds-14330a180d0c0c63053da6259ed95eac52b92910.tar.xz
office/fbreader: Updated for version 0.12.2
Diffstat (limited to 'office')
-rw-r--r--office/fbreader/README15
-rw-r--r--office/fbreader/doinst.sh1
-rw-r--r--office/fbreader/fbreader.SlackBuild24
-rw-r--r--office/fbreader/fbreader.info12
4 files changed, 24 insertions, 28 deletions
diff --git a/office/fbreader/README b/office/fbreader/README
index b18c145f7b..157784bd71 100644
--- a/office/fbreader/README
+++ b/office/fbreader/README
@@ -1,19 +1,6 @@
FBReader is e-book reader for Linux PDAs and desktop.
-- Supported formats are: fb2 e-book format (style attributes are not supported
- yet); HTML format (tables are not supported); CHM format (tables are not
- supported); plucker format (embedded images are supported, tables are not
- supported); Palmdoc (aportis doc); zTxt (Weasel format); TCR (psion text)
- format; RTF format (stylesheets and tables are not supported); OEB format
- (css and tables are not supported); OpenReader format (css and tables are not
- supported); Non-DRM'ed mobipocket format (tables are not supported); Plain
- text format.
-- Direct reading from tar, zip, gzip and bzip2 archives.
-- Automatically generated contents table.
-- Embedded images support.
-- Footnotes/hyperlinks support.
-
-Requires liblinebreak which can be found here at SBo.
+This requires liblinebreak.
This builds the Qt-based user interface by default; if you prefer to build
the GTK interface instead, run the script as follows:
diff --git a/office/fbreader/doinst.sh b/office/fbreader/doinst.sh
index 5fb28930db..4e8ba7071d 100644
--- a/office/fbreader/doinst.sh
+++ b/office/fbreader/doinst.sh
@@ -1,3 +1,4 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
diff --git a/office/fbreader/fbreader.SlackBuild b/office/fbreader/fbreader.SlackBuild
index 15de09985c..8199f255ca 100644
--- a/office/fbreader/fbreader.SlackBuild
+++ b/office/fbreader/fbreader.SlackBuild
@@ -1,10 +1,12 @@
#!/bin/sh
# Slackware build script for fbreader
-# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+# Originally written by Audrius Kazukauskas <audrius@neutrino.lt>
+# Maintained as of version 0.12.1 by Niels Horn <niels.horn@gmail.com>
+# revision date: 2010/02/11
PRGNAM=fbreader
-VERSION=0.10.7
+VERSION=0.12.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -17,13 +19,17 @@ OUTPUT=${OUTPUT:-/tmp}
# If you want to build the gtk interface instead, then change this
# value to 'gtk' or run the script like this:
# UI=gtk ./fbreader.SlackBuild
-# (or UI=qt4 for those who have Qt4 from -current)
-UI=${UI:-qt}
+UI=${UI:-qt4}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e # Exit on most errors
@@ -37,7 +43,7 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# We're building for desktop against Qt3
+# We're building for desktop against Qt4
# If you want to build against GTK+2, just change UI_TYPE to gtk
cat > makefiles/target.mk << EOF
TARGET_ARCH = desktop
@@ -48,7 +54,7 @@ EOF
# Add SLKCFLAGS
sed -i "s|CFLAGS =|CFLAGS = $SLKCFLAGS|" makefiles/arch/desktop.mk
-# Fix all Qt3 related flags
+# Fix all Qt3 related flags (just in case)
sed -i 's|moc-qt3|moc|' makefiles/arch/desktop.mk
sed -i 's|-I /usr/include/qt3|$(shell pkg-config --cflags qt-mt)|' makefiles/arch/desktop.mk
sed -i 's|-lqt-mt|$(shell pkg-config --libs qt-mt)|' makefiles/arch/desktop.mk
@@ -58,8 +64,8 @@ sed -i 's|moc-qt4|moc|' makefiles/arch/desktop.mk
sed -i 's|-I /usr/include/qt4|$(shell pkg-config --cflags QtGui)|' makefiles/arch/desktop.mk
sed -i 's|-lQtGui|$(shell pkg-config --libs QtGui)|' makefiles/arch/desktop.mk
-make
-make install DESTDIR=$PKG
+make LIBDIR=/usr/lib${LIBDIRSUFFIX}
+make install LIBDIR=/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
@@ -80,4 +86,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/fbreader/fbreader.info b/office/fbreader/fbreader.info
index 444608ff14..de4a2f9d5e 100644
--- a/office/fbreader/fbreader.info
+++ b/office/fbreader/fbreader.info
@@ -1,8 +1,10 @@
PRGNAM="fbreader"
-VERSION="0.10.7"
+VERSION="0.12.2"
HOMEPAGE="http://fbreader.org/"
-DOWNLOAD="http://fbreader.org/fbreader-sources-0.10.7.tgz"
-MD5SUM="145f4d2ba24c54288bad2d66ddd2baf2"
-MAINTAINER="Audrius Kazukauskas"
-EMAIL="audrius@neutrino.lt"
+DOWNLOAD="http://fbreader.org/fbreader-sources-0.12.2.tgz"
+MD5SUM="f67883a814e3bf74378d97b997867144"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Niels Horn"
+EMAIL="niels.horn@gmail.com"
APPROVED="dsomero"