summaryrefslogtreecommitdiffstats
path: root/python/PyAudio
diff options
context:
space:
mode:
author Giuseppe Scalzi <giuseppe@osgate.org>2011-10-28 22:55:48 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2011-10-28 22:55:48 -0200
commit116e90b41825a35e62fe5475cde8383e5c8aa074 (patch)
tree1bf00d8f52993f50216478c6d1b96516ec654f39 /python/PyAudio
parente77c15859798c9b9dd4770f07df154dfed1948c9 (diff)
downloadslackbuilds-116e90b41825a35e62fe5475cde8383e5c8aa074.tar.gz
slackbuilds-116e90b41825a35e62fe5475cde8383e5c8aa074.tar.xz
python/PyAudio: Added (PortAudio Python Bindings)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'python/PyAudio')
-rw-r--r--python/PyAudio/PyAudio.SlackBuild70
-rw-r--r--python/PyAudio/PyAudio.info10
-rw-r--r--python/PyAudio/README6
-rw-r--r--python/PyAudio/slack-desc19
4 files changed, 105 insertions, 0 deletions
diff --git a/python/PyAudio/PyAudio.SlackBuild b/python/PyAudio/PyAudio.SlackBuild
new file mode 100644
index 0000000000..263c5e59c4
--- /dev/null
+++ b/python/PyAudio/PyAudio.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for PyAudio
+
+# Written by Giuseppe Scalzi <giuseppe[at]osgate[dot]org>
+
+PRGNAM=PyAudio
+VERSION=${VERSION:-0.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/`echo $PRGNAM-$VERSION | tr "[:upper:]" "[:lower:]"`.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG INSTALL README PKG-INFO MANIFEST.in \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/PyAudio/PyAudio.info b/python/PyAudio/PyAudio.info
new file mode 100644
index 0000000000..899ecadc4b
--- /dev/null
+++ b/python/PyAudio/PyAudio.info
@@ -0,0 +1,10 @@
+PRGNAM="PyAudio"
+VERSION="0.2.4"
+HOMEPAGE="http://people.csail.mit.edu/hubert/pyaudio/"
+DOWNLOAD="http://people.csail.mit.edu/hubert/pyaudio/packages/pyaudio-0.2.4.tar.gz"
+MD5SUM="623809778f3d70254a25492bae63b575"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Giuseppe Scalzi"
+EMAIL="giuseppe@osgate.org"
+APPROVED="Niels Horn"
diff --git a/python/PyAudio/README b/python/PyAudio/README
new file mode 100644
index 0000000000..7274a3ca54
--- /dev/null
+++ b/python/PyAudio/README
@@ -0,0 +1,6 @@
+PyAudio provides Python bindings for PortAudio,
+the cross-platform audio I/O library.
+With PyAudio, you can easily use Python to
+play and record audio on a variety of platforms.
+
+Requires portaudio
diff --git a/python/PyAudio/slack-desc b/python/PyAudio/slack-desc
new file mode 100644
index 0000000000..5cf797934c
--- /dev/null
+++ b/python/PyAudio/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyAudio: PyAudio (PortAudio v19 Python Bindings)
+PyAudio:
+PyAudio: PyAudio provides Python bindings for PortAudio, the cross-platform
+PyAudio: audio I/O library. With PyAudio, you can easily use Python to
+PyAudio: play and record audio on a variety of platforms.
+PyAudio:
+PyAudio:
+PyAudio:
+PyAudio: http://people.csail.mit.edu/hubert/pyaudio/
+PyAudio:
+PyAudio: