summaryrefslogtreecommitdiffstats
path: root/python/PyGreSQL
diff options
context:
space:
mode:
author Christoph Willing <c.willing@uq.edu.au>2013-06-20 15:46:44 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2013-06-20 15:46:44 -0300
commit7f4c1410d9c1577e89ca90a34a04c8e1ecba547f (patch)
treea3a9590ca8449ffe3739be9a2796e77456a89213 /python/PyGreSQL
parent4d3519892f2ac5bbc6822922517943da1e5435ce (diff)
downloadslackbuilds-7f4c1410d9c1577e89ca90a34a04c8e1ecba547f.tar.gz
slackbuilds-7f4c1410d9c1577e89ca90a34a04c8e1ecba547f.tar.xz
python/PyGreSQL: Added (Python PostgreSQL Interfaces)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'python/PyGreSQL')
-rw-r--r--python/PyGreSQL/PyGreSQL.SlackBuild88
-rw-r--r--python/PyGreSQL/PyGreSQL.info10
-rw-r--r--python/PyGreSQL/README3
-rw-r--r--python/PyGreSQL/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/PyGreSQL/PyGreSQL.SlackBuild b/python/PyGreSQL/PyGreSQL.SlackBuild
new file mode 100644
index 0000000000..3a2a465c25
--- /dev/null
+++ b/python/PyGreSQL/PyGreSQL.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for PyGreSQL
+
+# Copyright 2013, Christoph Willing, Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PyGreSQL
+VERSION=${VERSION:-4.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -ev
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tgz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Build & install
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ docs/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/PyGreSQL/PyGreSQL.info b/python/PyGreSQL/PyGreSQL.info
new file mode 100644
index 0000000000..93e1dbfc8f
--- /dev/null
+++ b/python/PyGreSQL/PyGreSQL.info
@@ -0,0 +1,10 @@
+PRGNAM="PyGreSQL"
+VERSION="4.1.1"
+HOMEPAGE="http://www.pygresql.org"
+DOWNLOAD="https://pypi.python.org/packages/source/P/PyGreSQL/PyGreSQL-4.1.1.tgz"
+MD5SUM="71d0b8c5a382f635572eb52fee47cd08"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="postgresql"
+MAINTAINER="Christoph Willing"
+EMAIL="c.willing@uq.edu.au"
diff --git a/python/PyGreSQL/README b/python/PyGreSQL/README
new file mode 100644
index 0000000000..2ac39fc87d
--- /dev/null
+++ b/python/PyGreSQL/README
@@ -0,0 +1,3 @@
+PyGreSQL is an open-source Python module that interfaces to a PostgreSQL
+database. It embeds the PostgreSQL query library to allow easy use of the
+powerful PostgreSQL features from a Python script.
diff --git a/python/PyGreSQL/slack-desc b/python/PyGreSQL/slack-desc
new file mode 100644
index 0000000000..d05c2bc1ef
--- /dev/null
+++ b/python/PyGreSQL/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyGreSQL: PyGreSQL (Python PostgreSQL Interfaces)
+PyGreSQL:
+PyGreSQL: PyGreSQL is an open-source Python module that interfaces to a
+PyGreSQL: PostgreSQL database. It embeds the PostgreSQL query library to allow
+PyGreSQL: easy use of the powerful PostgreSQL features from a Python script.
+PyGreSQL:
+PyGreSQL:
+PyGreSQL:
+PyGreSQL:
+PyGreSQL:
+PyGreSQL: