summaryrefslogtreecommitdiffstats
path: root/python/cssselect
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2013-05-19 09:12:35 -0400
committer dsomero <xgizzmo@slackbuilds.org>2013-05-19 09:12:35 -0400
commitc4b114203682d507bc1ccd1f66d04f5c1a092d14 (patch)
treee5fb8dc37aebf6bbeefb85e35c085bbc33ffbb55 /python/cssselect
parent9a9a3588839db0e9885590e3f45ea7f2990d9bd8 (diff)
downloadslackbuilds-c4b114203682d507bc1ccd1f66d04f5c1a092d14.tar.gz
slackbuilds-c4b114203682d507bc1ccd1f66d04f5c1a092d14.tar.xz
python/cssselect: Updated for version 0.8.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/cssselect')
-rw-r--r--python/cssselect/README3
-rw-r--r--python/cssselect/cssselect.SlackBuild9
-rw-r--r--python/cssselect/cssselect.info6
3 files changed, 14 insertions, 4 deletions
diff --git a/python/cssselect/README b/python/cssselect/README
index 962b0278f1..9d2c7d4aae 100644
--- a/python/cssselect/README
+++ b/python/cssselect/README
@@ -1,3 +1,6 @@
cssselect parses CSS3 Selectors and translate them to XPath 1.0 expressions.
Such expressions can be used in lxml or another XPath engine to find the
matching elements in an XML or HTML document.
+
+Optionally: lxml can be installed for running tests. Sphinx and Pygments
+can be installed for man pages.
diff --git a/python/cssselect/cssselect.SlackBuild b/python/cssselect/cssselect.SlackBuild
index 22725a4746..c7ef13b66c 100644
--- a/python/cssselect/cssselect.SlackBuild
+++ b/python/cssselect/cssselect.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cssselect
-VERSION=${VERSION:-0.7.1}
+VERSION=${VERSION:-0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,6 +74,13 @@ python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Install man pages if Sphinx and Pygments are installed.
+if python -c 'import sphinx.pygments_styles' 2>/dev/null; then
+ python setup.py build_sphinx -b man
+ install -D -m 0644 docs/_build/man/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
+ gzip -9 $PKG/usr/man/man1/$PRGNAM.1
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS CHANGES LICENSE PKG-INFO README.rst docs/* \
diff --git a/python/cssselect/cssselect.info b/python/cssselect/cssselect.info
index 81aad3d5cc..a045317ec0 100644
--- a/python/cssselect/cssselect.info
+++ b/python/cssselect/cssselect.info
@@ -1,8 +1,8 @@
PRGNAM="cssselect"
-VERSION="0.7.1"
+VERSION="0.8"
HOMEPAGE="http://packages.python.org/cssselect/"
-DOWNLOAD="http://pypi.python.org/packages/source/c/cssselect/cssselect-0.7.1.tar.gz"
-MD5SUM="c6c5e9a2e7ca226ce03f6f67a771379c"
+DOWNLOAD="http://pypi.python.org/packages/source/c/cssselect/cssselect-0.8.tar.gz"
+MD5SUM="c4683e050351abcbbd5990b01f5344e2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="distribute"