summaryrefslogtreecommitdiffstats
path: root/python/cssutils
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-02-05 12:17:38 -0600
committer Robby Workman <rworkman@slackbuilds.org>2012-02-05 12:17:38 -0600
commitd24549b6c4585cd95e9426512808f29cbf07e525 (patch)
tree06a0fefe4e615b150013c62f9a2246c31abd3c29 /python/cssutils
parentbc7d3bff6fbe53914797f19912e150a6f876ebbe (diff)
downloadslackbuilds-d24549b6c4585cd95e9426512808f29cbf07e525.tar.gz
slackbuilds-d24549b6c4585cd95e9426512808f29cbf07e525.tar.xz
python/cssutils: Moved from Libraries
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/cssutils')
-rw-r--r--python/cssutils/README3
-rw-r--r--python/cssutils/cssutils.SlackBuild56
-rw-r--r--python/cssutils/cssutils.info10
-rw-r--r--python/cssutils/slack-desc19
4 files changed, 88 insertions, 0 deletions
diff --git a/python/cssutils/README b/python/cssutils/README
new file mode 100644
index 0000000000..8186cf6070
--- /dev/null
+++ b/python/cssutils/README
@@ -0,0 +1,3 @@
+A Python package to parse and build CSS Cascading Style Sheets.
+
+This requires distribute.
diff --git a/python/cssutils/cssutils.SlackBuild b/python/cssutils/cssutils.SlackBuild
new file mode 100644
index 0000000000..a985b5e11c
--- /dev/null
+++ b/python/cssutils/cssutils.SlackBuild
@@ -0,0 +1,56 @@
+#!/bin/sh
+# Slackware build script for cssutils
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=cssutils
+VERSION=0.9.8
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Change files from DOS to unix.
+for FILE in $(find . -type f -exec grep -Pl '\r\n' {} \;); do
+ sed -i 's/\r//g' $FILE
+done
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt COPYING* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/cssutils/cssutils.info b/python/cssutils/cssutils.info
new file mode 100644
index 0000000000..f88d75a48f
--- /dev/null
+++ b/python/cssutils/cssutils.info
@@ -0,0 +1,10 @@
+PRGNAM="cssutils"
+VERSION="0.9.8"
+HOMEPAGE="https://bitbucket.org/cthedot/cssutils"
+DOWNLOAD="http://pypi.python.org/packages/source/c/cssutils/cssutils-0.9.8.zip"
+MD5SUM="416af035c002150da7248a1944bd9cf9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"
diff --git a/python/cssutils/slack-desc b/python/cssutils/slack-desc
new file mode 100644
index 0000000000..9222023cd6
--- /dev/null
+++ b/python/cssutils/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+cssutils: cssutils (CSS parser and builder)
+cssutils:
+cssutils: A Python package to parse and build CSS Cascading Style Sheets.
+cssutils:
+cssutils: Homepage: http://code.google.com/p/cssutils/
+cssutils:
+cssutils:
+cssutils:
+cssutils:
+cssutils:
+cssutils: