summaryrefslogtreecommitdiffstats
path: root/python/jellyfish/jellyfish.SlackBuild
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-16 14:22:33 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-23 11:33:49 +0700
commit896508436d670012bec899ed64363c4b82b10d48 (patch)
tree973e78d2ba400a93d7e6edb070b5cbf831eddec1 /python/jellyfish/jellyfish.SlackBuild
parentccfef38374428a2084e70626615d4c8a0e6398fa (diff)
downloadslackbuilds-896508436d670012bec899ed64363c4b82b10d48.tar.gz
slackbuilds-896508436d670012bec899ed64363c4b82b10d48.tar.xz
python/jellyfish: Updated for version 1.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/jellyfish/jellyfish.SlackBuild')
-rw-r--r--python/jellyfish/jellyfish.SlackBuild45
1 files changed, 36 insertions, 9 deletions
diff --git a/python/jellyfish/jellyfish.SlackBuild b/python/jellyfish/jellyfish.SlackBuild
index 1af429bb8c..7fd0e39272 100644
--- a/python/jellyfish/jellyfish.SlackBuild
+++ b/python/jellyfish/jellyfish.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jellyfish
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2015-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -23,10 +23,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230916 46and2: Updated version, changed build process.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jellyfish
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,6 +59,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -72,21 +74,46 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-vendored-sources-$VERSION-$BUILD.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# patch pyproject.toml to allow maturin 1.x.x version
+patch -Np1 < $CWD/pyproject.toml.patch
+
+# patch Cargo.toml to exclude dist dir and get rid of build warning
+patch -Np1 < $CWD/Cargo.toml.patch
+
+# prevent cargo from using the network.
+# this only works because we have a vendored sources tarball with
+# everything cargo would have downloaded.
+export CARGO_NET_OFFLINE=true
+
+# prevent cargo from writing outside of $TMP
+export CARGO_HOME=$(pwd)/.cargo
+
+export PATH="/opt/rust16/bin:$PATH"
+if [ -z "$LD_LIBRARY_PATH" ]; then
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX"
+else
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX:$LD_LIBRARY_PATH"
+fi
+
+export PYTHONPATH=/opt/python3.9/site-packages/
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md PKG-INFO LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md PKG-INFO LICENSE docs/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install