summaryrefslogtreecommitdiffstats
path: root/python/pygrametl
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-02-17 18:26:25 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-02-18 14:59:55 -0600
commit4246fafdf95372e2fc7aafc7d82d1d08062618a7 (patch)
tree9db18a9c976de01f280ac969f0af2b8cfaa9d2be /python/pygrametl
parent291b822a97b6c820bb88676698998a5f32554402 (diff)
downloadslackbuilds-4246fafdf95372e2fc7aafc7d82d1d08062618a7.tar.gz
slackbuilds-4246fafdf95372e2fc7aafc7d82d1d08062618a7.tar.xz
python/pygrametl: Added (ETL programming in Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pygrametl')
-rw-r--r--python/pygrametl/README4
-rw-r--r--python/pygrametl/pygrametl.SlackBuild85
-rw-r--r--python/pygrametl/pygrametl.info10
-rw-r--r--python/pygrametl/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/pygrametl/README b/python/pygrametl/README
new file mode 100644
index 0000000000..c428e00533
--- /dev/null
+++ b/python/pygrametl/README
@@ -0,0 +1,4 @@
+ETL programming in Python.
+pygrametl (pronounced py-gram-e-t-l) is a Python framework which offers
+commonly used functionality for development of Extract-Transform-Load
+(ETL) processes.
diff --git a/python/pygrametl/pygrametl.SlackBuild b/python/pygrametl/pygrametl.SlackBuild
new file mode 100644
index 0000000000..07a0a390da
--- /dev/null
+++ b/python/pygrametl/pygrametl.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for pygrametl
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pygrametl
+VERSION=${VERSION:-2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pygrametl/pygrametl.info b/python/pygrametl/pygrametl.info
new file mode 100644
index 0000000000..dbcdce6908
--- /dev/null
+++ b/python/pygrametl/pygrametl.info
@@ -0,0 +1,10 @@
+PRGNAM="pygrametl"
+VERSION="2.2"
+HOMEPAGE="http://pygrametl.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pygrametl/pygrametl-2.2.tar.gz"
+MD5SUM="3b733d3f13b55629a5c864e8737d57fd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pygrametl/slack-desc b/python/pygrametl/slack-desc
new file mode 100644
index 0000000000..115e9b1d14
--- /dev/null
+++ b/python/pygrametl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pygrametl: pygrametl (ETL programming in Python)
+pygrametl:
+pygrametl: pygrametl (pronounced py-gram-e-t-l) is a Python framework which
+pygrametl: offers commonly used functionality for development of Extract-
+pygrametl: Transform-Load (ETL) processes.
+pygrametl:
+pygrametl: Homepage: http://pygrametl.org/
+pygrametl:
+pygrametl:
+pygrametl:
+pygrametl: