summaryrefslogtreecommitdiffstats
path: root/python/pygsl
diff options
context:
space:
mode:
author Fellype do Nascimento <fellype (at) gmail.com>2017-07-18 22:31:01 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-22 06:56:08 +0700
commit1289094ea739a9fd9ebe6195dc888cae0edbd341 (patch)
tree7aa76e39bb7c2656f808b50ff535d5e9f08a6e73 /python/pygsl
parent50f5c031fbc8d29d0e22434853c119fe03ea5b4c (diff)
downloadslackbuilds-1289094ea739a9fd9ebe6195dc888cae0edbd341.tar.gz
slackbuilds-1289094ea739a9fd9ebe6195dc888cae0edbd341.tar.xz
python/pygsl: Added (python interface for GSL).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/pygsl')
-rw-r--r--python/pygsl/README4
-rw-r--r--python/pygsl/pygsl.SlackBuild90
-rw-r--r--python/pygsl/pygsl.info10
-rw-r--r--python/pygsl/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/python/pygsl/README b/python/pygsl/README
new file mode 100644
index 0000000000..4d0c324a01
--- /dev/null
+++ b/python/pygsl/README
@@ -0,0 +1,4 @@
+PyGSL (python interface for GSL)
+
+PyGSL is a Python interface for the GNU scientific library (GSL).
+The wrapper covers nearly everything GSL provides.
diff --git a/python/pygsl/pygsl.SlackBuild b/python/pygsl/pygsl.SlackBuild
new file mode 100644
index 0000000000..682a17e01b
--- /dev/null
+++ b/python/pygsl/pygsl.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for PyGSL
+# Based on the Slackware 14.2 SlackBuild
+#
+# Copyright 2017, Fellype do Nascimento, Campinas - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pygsl
+VERSION=${VERSION:-2.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py config
+python setup.py build
+python setup.py install --root=$PKG --prefix=/usr
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog COPYING CREDITS README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pygsl/pygsl.info b/python/pygsl/pygsl.info
new file mode 100644
index 0000000000..4d0fb9cb7d
--- /dev/null
+++ b/python/pygsl/pygsl.info
@@ -0,0 +1,10 @@
+PRGNAM="pygsl"
+VERSION="2.2.0"
+HOMEPAGE="https://sourceforge.net/projects/pygsl/"
+DOWNLOAD="https://download.sourceforge.net/pygsl/pygsl-2.2.0.tar.gz"
+MD5SUM="9eb0dcead1ce912e8ae0e835eeb4d4b4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="numpy"
+MAINTAINER="Fellype do Nascimento"
+EMAIL="fellype (at) gmail.com"
diff --git a/python/pygsl/slack-desc b/python/pygsl/slack-desc
new file mode 100644
index 0000000000..f53765755c
--- /dev/null
+++ b/python/pygsl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pygsl: pygsl (python interface for GSL)
+pygsl:
+pygsl: PyGSL is a Python interface for the GNU scientific library (GSL).
+pygsl: The wrapper covers nearly everything GSL provides.
+pygsl:
+pygsl:
+pygsl:
+pygsl:
+pygsl:
+pygsl:
+pygsl: