summaryrefslogtreecommitdiffstats
path: root/python/pyinotify
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2015-12-31 12:51:54 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-12-31 12:51:54 +0700
commit2340dc06109bdcb1580af45318b7db17b6686167 (patch)
treedc253a8865f32cc217008edb92e4431628b32c02 /python/pyinotify
parent768e6d4739a1cfe87c1c65f112ab364b58812b23 (diff)
downloadslackbuilds-2340dc06109bdcb1580af45318b7db17b6686167.tar.gz
slackbuilds-2340dc06109bdcb1580af45318b7db17b6686167.tar.xz
python/pyinotify: Updated for version 0.9.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyinotify')
-rw-r--r--python/pyinotify/README7
-rw-r--r--python/pyinotify/pyinotify.SlackBuild36
-rw-r--r--python/pyinotify/pyinotify.info6
3 files changed, 36 insertions, 13 deletions
diff --git a/python/pyinotify/README b/python/pyinotify/README
index 54db578c8f..8d2e7cf339 100644
--- a/python/pyinotify/README
+++ b/python/pyinotify/README
@@ -3,4 +3,9 @@ Pyinotify relies on a Linux Kernel feature (merged in kernel 2.6.13)
called inotify. inotify is an event-driven notifier, its notifications
are exported from kernel space to user space through three system calls.
-pysetuptools and python3 are optional deps that will be used if present.
+Optional dependencies: pysetuptools and python3
+
+Note: To install python3 bindings pass the variable PYTHON3=yes to the
+slackbuild.
+
+ # PYTHON3=yes ./pyinotify.SlackBuild
diff --git a/python/pyinotify/pyinotify.SlackBuild b/python/pyinotify/pyinotify.SlackBuild
index 40eedd041a..57c60a6744 100644
--- a/python/pyinotify/pyinotify.SlackBuild
+++ b/python/pyinotify/pyinotify.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for pyinotify
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyinotify
-VERSION=${VERSION:-0.9.4}
+VERSION=${VERSION:-0.9.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,25 +50,25 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Compile the C extension.
sed -i '/^compile_ext_mod/s|=.*|= True|' setup.py
python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKS COPYING PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKS COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pyinotify/pyinotify.info b/python/pyinotify/pyinotify.info
index 588c9cbf42..2c7534e470 100644
--- a/python/pyinotify/pyinotify.info
+++ b/python/pyinotify/pyinotify.info
@@ -1,8 +1,8 @@
PRGNAM="pyinotify"
-VERSION="0.9.4"
+VERSION="0.9.6"
HOMEPAGE="https://github.com/seb-m/pyinotify"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyinotify/pyinotify-0.9.4.tar.gz"
-MD5SUM="701c91854d241514ede7ffe72086566d"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyinotify/pyinotify-0.9.6.tar.gz"
+MD5SUM="8e580fa1ff3971f94a6f81672b76c406"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""