summaryrefslogtreecommitdiffstats
path: root/python/pymongo/pymongo.SlackBuild
diff options
context:
space:
mode:
author Christoph Willing <chris.willing@iinet.net.au>2014-06-23 00:57:45 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-06-23 00:57:45 +0700
commit03a2c5d9f982cddd82e780c39c6485e0d0d520f5 (patch)
tree193c5c300e81becaeaf58d3bf18289f7178c5c5f /python/pymongo/pymongo.SlackBuild
parentfabf9f60fa50b3a4097bc82877c8e6bba2723272 (diff)
downloadslackbuilds-03a2c5d9f982cddd82e780c39c6485e0d0d520f5.tar.gz
slackbuilds-03a2c5d9f982cddd82e780c39c6485e0d0d520f5.tar.xz
python/pymongo: Updated for version 2.7.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pymongo/pymongo.SlackBuild')
-rw-r--r--python/pymongo/pymongo.SlackBuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/python/pymongo/pymongo.SlackBuild b/python/pymongo/pymongo.SlackBuild
index edd27c6c3c..1dfab5cd98 100644
--- a/python/pymongo/pymongo.SlackBuild
+++ b/python/pymongo/pymongo.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pymongo
-# Copyright 2013 Christoph Willing, Australia
+# Copyright 2013-2014 Christoph Willing, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pymongo
-VERSION=${VERSION:-2.4.2}
+VERSION=${VERSION:-2.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,12 +62,12 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-#chown -R root:root .
+chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Build & install
python setup.py install --root=$PKG
@@ -77,12 +77,8 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
-cp -a \
- LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- doc/_build/$VERSION/* \
- $PKG/usr/doc/$PRGNAM-$VERSION/html/
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/_build/$VERSION/* $PKG/usr/doc/$PRGNAM-$VERSION/html/
rm -rf $PKG/usr/doc/$PRGNAM-$VERSION/html/_sources
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild