summaryrefslogtreecommitdiffstats
path: root/python/pyserial
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/pyserial
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
slackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pyserial')
-rw-r--r--python/pyserial/README1
-rw-r--r--python/pyserial/pyserial.SlackBuild55
-rw-r--r--python/pyserial/pyserial.info10
-rw-r--r--python/pyserial/slack-desc19
4 files changed, 85 insertions, 0 deletions
diff --git a/python/pyserial/README b/python/pyserial/README
new file mode 100644
index 0000000000..bc6ddf9364
--- /dev/null
+++ b/python/pyserial/README
@@ -0,0 +1 @@
+pyserial is a python module that encapsulates access to a serial port.
diff --git a/python/pyserial/pyserial.SlackBuild b/python/pyserial/pyserial.SlackBuild
new file mode 100644
index 0000000000..40ddd60fea
--- /dev/null
+++ b/python/pyserial/pyserial.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# Slackware build script for pyserial
+
+# Written by Grissiom <chaos.proton@gmail.com>
+# Updated by Dustin Schnee <schnee72{at}gmail{dot}com>
+
+PRGNAM=pyserial
+VERSION=${VERSION:-2.5_rc2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRC_VERSION=$(printf $VERSION | tr _ -)
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRC_VERSION
+tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
+cd $PRGNAM-$SRC_VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt LICENSE.txt README.txt PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyserial/pyserial.info b/python/pyserial/pyserial.info
new file mode 100644
index 0000000000..5c22421b62
--- /dev/null
+++ b/python/pyserial/pyserial.info
@@ -0,0 +1,10 @@
+PRGNAM="pyserial"
+VERSION="2.5_rc2"
+HOMEPAGE="http://pyserial.sourceforge.net/index.html"
+DOWNLOAD="http://downloads.sourceforge.net/pyserial/pyserial-2.5-rc2.tar.gz"
+MD5SUM="feee06e28ff5337c010c5e326ec4efd3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Grissiom"
+EMAIL="chaos.proton@gmail.com"
+APPROVED="rworkman"
diff --git a/python/pyserial/slack-desc b/python/pyserial/slack-desc
new file mode 100644
index 0000000000..95859372c1
--- /dev/null
+++ b/python/pyserial/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyserial: pyserial (python module for accessing the serial port)
+pyserial:
+pyserial: This module encapsulates the access for the serial port. It provides
+pyserial: backends for Python running on Windows, Linux, BSD (possibly any POSIX
+pyserial: compliant system), Jython and IronPython (.NET and Mono).
+pyserial:
+pyserial: Homepage: http://pyserial.sourceforge.net
+pyserial:
+pyserial:
+pyserial:
+pyserial: