summaryrefslogtreecommitdiffstats
path: root/python/python-tlslite
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-10 06:26:54 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-10 23:55:50 +0700
commit7ad79080d1548774276f328e873f007cfc794224 (patch)
tree0d86eb323f422ef793c907a3daf486e81bb9a279 /python/python-tlslite
parentf3b8e9d4db11e5a692b726e63b19b3e74a910db1 (diff)
downloadslackbuilds-7ad79080d1548774276f328e873f007cfc794224.tar.gz
slackbuilds-7ad79080d1548774276f328e873f007cfc794224.tar.xz
python/python-tlslite: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-tlslite')
-rw-r--r--python/python-tlslite/python-tlslite.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/python-tlslite/python-tlslite.SlackBuild b/python/python-tlslite/python-tlslite.SlackBuild
index 2d780c1244..65cf093796 100644
--- a/python/python-tlslite/python-tlslite.SlackBuild
+++ b/python/python-tlslite/python-tlslite.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-tlslite
-# Copyright 2015-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -55,7 +55,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Add Python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true