summaryrefslogtreecommitdiffstats
path: root/python/python3-ipython
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-04-18 07:10:48 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-18 07:10:48 +0700
commitb5dfd1fdfd8a609bc2274a7860fd7d1e0c977895 (patch)
treeba9d1a2f64f3d7d4e8bae873345da3536646e7b0 /python/python3-ipython
parentfee8fb252aa5804fa9a6c8925a2021b81ca21e11 (diff)
downloadslackbuilds-b5dfd1fdfd8a609bc2274a7860fd7d1e0c977895.tar.gz
slackbuilds-b5dfd1fdfd8a609bc2274a7860fd7d1e0c977895.tar.xz
python/python3-ipython: Added (an enhanced Python 3 shell).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-ipython')
-rw-r--r--python/python3-ipython/README5
-rw-r--r--python/python3-ipython/python3-ipython.SlackBuild82
-rw-r--r--python/python3-ipython/python3-ipython.info10
-rw-r--r--python/python3-ipython/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python3-ipython/README b/python/python3-ipython/README
new file mode 100644
index 0000000000..9ab81e2a13
--- /dev/null
+++ b/python/python3-ipython/README
@@ -0,0 +1,5 @@
+IPython is a replacement shell for Python programming. It offers an
+enhanced Python 3 shell for the terminal.
+
+This package no longer provides IPython notebook functionality. This is
+now provided with the jupyter-notebook and python3-jupyter-ipykernel packages.
diff --git a/python/python3-ipython/python3-ipython.SlackBuild b/python/python3-ipython/python3-ipython.SlackBuild
new file mode 100644
index 0000000000..d3bec47ddd
--- /dev/null
+++ b/python/python3-ipython/python3-ipython.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# SlackBuild for IPython
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=ipython
+PRGNAM=python3-$SRCNAM
+VERSION=${VERSION:-5.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+DOCS=${DOCS:-no}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python3 setup.py install --root="$PKG"
+rm $PKG/usr/bin/iptest
+rm $PKG/usr/bin/ipython
+
+mkdir -p $PKG/usr/man/man1
+mv $PKG/usr/share/man/man1/$SRCNAM.1 $PKG/usr/man/man1/${SRCNAM}3.1
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# Delete now empty directory
+rm -rf $PKG/usr/share
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
+cp COPYING.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-ipython/python3-ipython.info b/python/python3-ipython/python3-ipython.info
new file mode 100644
index 0000000000..a94fb42305
--- /dev/null
+++ b/python/python3-ipython/python3-ipython.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-ipython"
+VERSION="5.3.0"
+HOMEPAGE="http://ipython.org"
+DOWNLOAD="https://github.com/ipython/ipython/archive/5.3.0/ipython-5.3.0.tar.gz"
+MD5SUM="30045499fa745e2f1893cadcba3f94c5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-decorator python3-pexpect python3-pickleshare python3-prompt_toolkit python3-Pygments python3-simplegeneric python3-traitlets"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-ipython/slack-desc b/python/python3-ipython/slack-desc
new file mode 100644
index 0000000000..fabef98df3
--- /dev/null
+++ b/python/python3-ipython/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-ipython: python3-ipython (an enhanced Python 3 shell)
+python3-ipython:
+python3-ipython: IPython is a multiplatform project that offers an enhanced Python 3
+python3-ipython: shell designed for efficient interactive work.
+python3-ipython:
+python3-ipython:
+python3-ipython:
+python3-ipython:
+python3-ipython:
+python3-ipython:
+python3-ipython: