summaryrefslogtreecommitdiffstats
path: root/python/python3-jupyter-ipykernel
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-04-18 07:22:04 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-18 07:22:04 +0700
commita43aadaa0b53bd79c6e1c23097498633b2fd2f41 (patch)
treef01055ce745259a295b2a5a03ee862e3ff4d86b2 /python/python3-jupyter-ipykernel
parentb5dfd1fdfd8a609bc2274a7860fd7d1e0c977895 (diff)
downloadslackbuilds-a43aadaa0b53bd79c6e1c23097498633b2fd2f41.tar.gz
slackbuilds-a43aadaa0b53bd79c6e1c23097498633b2fd2f41.tar.xz
python/python3-jupyter-ipykernel: Added (Kernel for Jupyter).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-jupyter-ipykernel')
-rw-r--r--python/python3-jupyter-ipykernel/README1
-rw-r--r--python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.SlackBuild87
-rw-r--r--python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.info10
-rw-r--r--python/python3-jupyter-ipykernel/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python3-jupyter-ipykernel/README b/python/python3-jupyter-ipykernel/README
new file mode 100644
index 0000000000..7f0e2020c3
--- /dev/null
+++ b/python/python3-jupyter-ipykernel/README
@@ -0,0 +1 @@
+IPython Kernel for Jupyter supporting Python 3.
diff --git a/python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.SlackBuild b/python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.SlackBuild
new file mode 100644
index 0000000000..c7fb86f34d
--- /dev/null
+++ b/python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python3-jupyter-ipykernel
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=ipykernel
+PRGNAM=python3-jupyter-$SRCNAM
+VERSION=${VERSION:-4.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s/executable='python'/executable='python3'/" setup.py
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.info b/python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.info
new file mode 100644
index 0000000000..c5e842b3fa
--- /dev/null
+++ b/python/python3-jupyter-ipykernel/python3-jupyter-ipykernel.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-jupyter-ipykernel"
+VERSION="4.6.0"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/i/ipykernel/ipykernel-4.6.0.tar.gz"
+MD5SUM="0ece8acd7866261b07c3eb58e134b510"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-ipython jupyter-notebook"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-jupyter-ipykernel/slack-desc b/python/python3-jupyter-ipykernel/slack-desc
new file mode 100644
index 0000000000..2f95819fa7
--- /dev/null
+++ b/python/python3-jupyter-ipykernel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-jupyter-ipykernel: python3-jupyter-ipykernel (Python 3 Kernel for Jupyter)
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel: IPython Kernel for Jupyter supporting Python 3.
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel:
+python3-jupyter-ipykernel: