summaryrefslogtreecommitdiffstats
path: root/python/python3
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2013-12-31 06:47:24 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-07 11:13:59 -0600
commit4ffc3b91a594a6848a893560a559346fbd9d3c89 (patch)
treed04b11c2c349fb7264b371d662d27b1f259773d5 /python/python3
parent14ea9bbcbcfa131e7ce6dd0bb8b66041fa0f2cea (diff)
downloadslackbuilds-4ffc3b91a594a6848a893560a559346fbd9d3c89.tar.gz
slackbuilds-4ffc3b91a594a6848a893560a559346fbd9d3c89.tar.xz
python/python3: Updated for version 3.3.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3')
-rw-r--r--python/python3/patches/python3.no-static-library.diff16
-rw-r--r--python/python3/patches/python3.x86_64.diff68
-rw-r--r--python/python3/python3.SlackBuild8
-rw-r--r--python/python3/python3.info10
4 files changed, 53 insertions, 49 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index c0e48bd9fb..fa28c0d615 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
---- Python-3.3.1.orig/Makefile.pre.in 2013-04-06 10:41:48.000000000 +0300
-+++ Python-3.3.1/Makefile.pre.in 2013-04-21 15:43:24.509324568 +0300
-@@ -471,7 +471,7 @@
+diff -uar Python-3.3.3.orig/Makefile.pre.in Python-3.3.3/Makefile.pre.in
+--- Python-3.3.3.orig/Makefile.pre.in 2013-11-17 09:22:55.000000000 +0200
++++ Python-3.3.3/Makefile.pre.in 2013-12-29 13:38:17.787830460 +0200
+@@ -475,7 +475,7 @@
# Build the interpreter
@@ -10,8 +10,8 @@ diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -495,18 +495,6 @@
- $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' \
+@@ -500,18 +500,6 @@
+ _TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
-# Build static library
@@ -29,7 +29,7 @@ diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -596,7 +584,7 @@
+@@ -601,7 +589,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1191,18 +1179,6 @@
+@@ -1197,18 +1185,6 @@
else true; \
fi; \
done
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 31ea63fdab..5d5ce5f726 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.3.0.orig/Lib/distutils/command/install.py Python-3.3.0/Lib/distutils/command/install.py
---- Python-3.3.0.orig/Lib/distutils/command/install.py 2012-09-29 11:00:27.000000000 +0300
-+++ Python-3.3.0/Lib/distutils/command/install.py 2012-10-09 21:15:04.125445023 +0300
+diff -uar Python-3.3.3.orig/Lib/distutils/command/install.py Python-3.3.3/Lib/distutils/command/install.py
+--- Python-3.3.3.orig/Lib/distutils/command/install.py 2013-11-17 09:22:30.000000000 +0200
++++ Python-3.3.3/Lib/distutils/command/install.py 2013-12-29 13:48:10.102637141 +0200
@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
@@ -21,10 +21,10 @@ diff -uar Python-3.3.0.orig/Lib/distutils/command/install.py Python-3.3.0/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.3.0.orig/Lib/distutils/sysconfig.py Python-3.3.0/Lib/distutils/sysconfig.py
---- Python-3.3.0.orig/Lib/distutils/sysconfig.py 2012-09-29 11:00:28.000000000 +0300
-+++ Python-3.3.0/Lib/distutils/sysconfig.py 2012-10-09 21:16:03.057946912 +0300
-@@ -140,7 +140,7 @@
+diff -uar Python-3.3.3.orig/Lib/distutils/sysconfig.py Python-3.3.3/Lib/distutils/sysconfig.py
+--- Python-3.3.3.orig/Lib/distutils/sysconfig.py 2013-11-17 09:22:30.000000000 +0200
++++ Python-3.3.3/Lib/distutils/sysconfig.py 2013-12-29 13:48:10.103637173 +0200
+@@ -144,7 +144,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,9 +33,10 @@ diff -uar Python-3.3.0.orig/Lib/distutils/sysconfig.py Python-3.3.0/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.3.0.orig/Lib/site.py Python-3.3.0/Lib/site.py
---- Python-3.3.0.orig/Lib/site.py 2012-09-29 11:00:31.000000000 +0300
-+++ Python-3.3.0/Lib/site.py 2012-10-09 21:17:48.131059160 +0300
+Only in Python-3.3.3/Lib/distutils: sysconfig.py.orig
+diff -uar Python-3.3.3.orig/Lib/site.py Python-3.3.3/Lib/site.py
+--- Python-3.3.3.orig/Lib/site.py 2013-11-17 09:22:38.000000000 +0200
++++ Python-3.3.3/Lib/site.py 2013-12-29 13:48:10.103637173 +0200
@@ -303,13 +303,13 @@
if sys.platform in ('os2emx', 'riscos'):
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
@@ -52,9 +53,9 @@ diff -uar Python-3.3.0.orig/Lib/site.py Python-3.3.0/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.3.0.orig/Lib/sysconfig.py Python-3.3.0/Lib/sysconfig.py
---- Python-3.3.0.orig/Lib/sysconfig.py 2012-09-29 11:00:31.000000000 +0300
-+++ Python-3.3.0/Lib/sysconfig.py 2012-10-09 21:24:26.697695600 +0300
+diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
+--- Python-3.3.3.orig/Lib/sysconfig.py 2013-11-17 09:22:39.000000000 +0200
++++ Python-3.3.3/Lib/sysconfig.py 2013-12-29 13:48:10.103637173 +0200
@@ -21,10 +21,10 @@
_INSTALL_SCHEMES = {
@@ -100,10 +101,10 @@ diff -uar Python-3.3.0.orig/Lib/sysconfig.py Python-3.3.0/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.3.0.orig/Lib/venv/__init__.py Python-3.3.0/Lib/venv/__init__.py
---- Python-3.3.0.orig/Lib/venv/__init__.py 2012-09-29 11:00:40.000000000 +0300
-+++ Python-3.3.0/Lib/venv/__init__.py 2013-02-10 13:29:16.859718301 +0200
-@@ -127,7 +127,7 @@
+diff -uar Python-3.3.3.orig/Lib/venv/__init__.py Python-3.3.3/Lib/venv/__init__.py
+--- Python-3.3.3.orig/Lib/venv/__init__.py 2013-11-17 09:22:53.000000000 +0200
++++ Python-3.3.3/Lib/venv/__init__.py 2013-12-29 13:48:10.103637173 +0200
+@@ -117,7 +117,7 @@
else:
binname = 'bin'
incpath = 'include'
@@ -112,10 +113,11 @@ diff -uar Python-3.3.0.orig/Lib/venv/__init__.py Python-3.3.0/Lib/venv/__init__.
context.inc_path = path = os.path.join(env_dir, incpath)
create_if_needed(path)
create_if_needed(libpath)
-diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
---- Python-3.3.0.orig/Makefile.pre.in 2012-09-29 11:00:41.000000000 +0300
-+++ Python-3.3.0/Makefile.pre.in 2012-10-09 21:26:05.949858929 +0300
-@@ -108,7 +108,7 @@
+Only in Python-3.3.3/Lib/venv: __init__.py.orig
+diff -uar Python-3.3.3.orig/Makefile.pre.in Python-3.3.3/Makefile.pre.in
+--- Python-3.3.3.orig/Makefile.pre.in 2013-11-17 09:22:55.000000000 +0200
++++ Python-3.3.3/Makefile.pre.in 2013-12-29 13:48:10.104637203 +0200
+@@ -115,7 +115,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -124,9 +126,10 @@ diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.3.0.orig/Modules/getpath.c Python-3.3.0/Modules/getpath.c
---- Python-3.3.0.orig/Modules/getpath.c 2012-09-29 11:00:45.000000000 +0300
-+++ Python-3.3.0/Modules/getpath.c 2012-10-09 21:30:59.047390113 +0300
+Only in Python-3.3.3: Makefile.pre.in.orig
+diff -uar Python-3.3.3.orig/Modules/getpath.c Python-3.3.3/Modules/getpath.c
+--- Python-3.3.3.orig/Modules/getpath.c 2013-11-17 09:23:01.000000000 +0200
++++ Python-3.3.3/Modules/getpath.c 2013-12-29 13:48:10.104637203 +0200
@@ -122,8 +122,8 @@
#endif
@@ -147,7 +150,7 @@ diff -uar Python-3.3.0.orig/Modules/getpath.c Python-3.3.0/Modules/getpath.c
static void
reduce(wchar_t *dir)
-@@ -677,7 +677,7 @@
+@@ -685,7 +685,7 @@
}
else
wcsncpy(zip_path, _prefix, MAXPATHLEN);
@@ -156,7 +159,7 @@ diff -uar Python-3.3.0.orig/Modules/getpath.c Python-3.3.0/Modules/getpath.c
bufsz = wcslen(zip_path); /* Replace "00" with version */
zip_path[bufsz - 6] = VERSION[0];
zip_path[bufsz - 5] = VERSION[2];
-@@ -687,7 +687,7 @@
+@@ -695,7 +695,7 @@
fprintf(stderr,
"Could not find platform dependent libraries <exec_prefix>\n");
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
@@ -165,10 +168,11 @@ diff -uar Python-3.3.0.orig/Modules/getpath.c Python-3.3.0/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.3.0.orig/setup.py Python-3.3.0/setup.py
---- Python-3.3.0.orig/setup.py 2012-09-29 11:00:50.000000000 +0300
-+++ Python-3.3.0/setup.py 2012-10-09 21:33:43.444006602 +0300
-@@ -459,7 +459,7 @@
+Only in Python-3.3.3/Modules: getpath.c.orig
+diff -uar Python-3.3.3.orig/setup.py Python-3.3.3/setup.py
+--- Python-3.3.3.orig/setup.py 2013-11-17 09:23:09.000000000 +0200
++++ Python-3.3.3/setup.py 2013-12-29 13:48:10.105637233 +0200
+@@ -439,7 +439,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -177,7 +181,7 @@ diff -uar Python-3.3.0.orig/setup.py Python-3.3.0/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -729,11 +729,11 @@
+@@ -712,11 +712,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -191,7 +195,7 @@ diff -uar Python-3.3.0.orig/setup.py Python-3.3.0/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -770,8 +770,8 @@
+@@ -753,8 +753,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index 9365613d7e..027473b366 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3
-VERSION=${VERSION:-3.3.2}
+VERSION=${VERSION:-3.3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -66,13 +66,13 @@ rm -rf Python-$VERSION
tar xvf $CWD/Python-$VERSION.tar.xz
cd Python-$VERSION
-patch -p1 < $CWD/patches/python3.readline.set_pre_input_hook.diff
+patch -p1 -i $CWD/patches/python3.readline.set_pre_input_hook.diff
# We don't want a large libpython*.a:
-patch -p1 < $CWD/patches/python3.no-static-library.diff
+patch -p1 -i $CWD/patches/python3.no-static-library.diff
if [ "$ARCH" = "x86_64" ]; then
# Install to lib64 instead of lib:
- patch -p1 < $CWD/patches/python3.x86_64.diff
+ patch -p1 -i $CWD/patches/python3.x86_64.diff
fi
# Fix python3 path in cgi.py.
diff --git a/python/python3/python3.info b/python/python3/python3.info
index 40eb689406..ed180121bf 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,10 +1,10 @@
PRGNAM="python3"
-VERSION="3.3.2"
+VERSION="3.3.3"
HOMEPAGE="http://python.org/"
-DOWNLOAD="http://python.org/ftp/python/3.3.2/Python-3.3.2.tar.xz \
- http://python.org/ftp/python/doc/3.3.2/python-3.3.2-docs-html.tar.bz2"
-MD5SUM="c94b78ea3b68a9bbc9906af4d5b4fdc7 \
- b5eee2b290338fb08c1512bfc79bb999"
+DOWNLOAD="http://python.org/ftp/python/3.3.3/Python-3.3.3.tar.xz \
+ http://python.org/ftp/python/doc/3.3.3/python-3.3.3-docs-html.tar.bz2"
+MD5SUM="4ca001c5586eb0744e3174bc75c6fba8 \
+ ed20d57923a9f76f62f6122aa12be08f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""