summaryrefslogtreecommitdiffstats
path: root/python/six
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-12-26 22:00:56 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-27 17:56:19 +0100
commitee936c7505b97c35f33cdd5cc29a296d3afe797c (patch)
treef9055ed7d0a5aa6ccaa4a6812d674ec7ff5e30fa /python/six
parent2fb3b2e6ce9f3d0a5032721b0f383495630fa1bf (diff)
downloadslackbuilds-ee936c7505b97c35f33cdd5cc29a296d3afe797c.tar.gz
slackbuilds-ee936c7505b97c35f33cdd5cc29a296d3afe797c.tar.xz
python/six: Added (Python 2 and 3 compatibility utilities).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/six')
-rw-r--r--python/six/README7
-rw-r--r--python/six/six.SlackBuild83
-rw-r--r--python/six/six.info10
-rw-r--r--python/six/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/six/README b/python/six/README
new file mode 100644
index 0000000000..6207b716e7
--- /dev/null
+++ b/python/six/README
@@ -0,0 +1,7 @@
+Six is a Python 2 and 3 compatibility library. It provides utility functions
+for smoothing over the differences between the Python versions with the goal
+of writing Python code that is compatible on both Python versions. See the
+documentation for more information on what is provided.
+
+Optional: html documentation and man pages will be installed if pygments and
+Sphinx are installed.
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
new file mode 100644
index 0000000000..365b7f6427
--- /dev/null
+++ b/python/six/six.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/sh
+
+# Slackware build script for six
+
+# Copyright 2012 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=six
+VERSION=${VERSION:-1.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Build and install documentation if sphinx and pygments are installed.
+if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
+ make -j1 -C documentation man singlehtml
+ install -D -m 0644 documentation/_build/man/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
+ gzip -9 $PKG/usr/man/man?/*.?
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+[ -d documentation/_build/singlehtml ] && \
+ cp -a documentation/_build/singlehtml/index.html \
+ documentation/_build/singlehtml/_static \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 '{}' \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/six/six.info b/python/six/six.info
new file mode 100644
index 0000000000..e611d18e5a
--- /dev/null
+++ b/python/six/six.info
@@ -0,0 +1,10 @@
+PRGNAM="six"
+VERSION="1.2.0"
+HOMEPAGE="http://pypi.python.org/pypi/six/"
+DOWNLOAD="http://pypi.python.org/packages/source/s/six/six-1.2.0.tar.gz"
+MD5SUM="2a5d1afc79912832ac78fd38e3d75d7e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/six/slack-desc b/python/six/slack-desc
new file mode 100644
index 0000000000..85bacee5d3
--- /dev/null
+++ b/python/six/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+six: six (Python 2 and 3 compatibility utilities)
+six:
+six: Six is a Python 2 and 3 compatibility library. It provides utility
+six: functions for smoothing over the differences between the Python
+six: versions with the goal of writing Python code that is compatible on
+six: both Python versions. See the documentation for more information on
+six: what is provided.
+six:
+six: Homepage: http://pypi.python.org/pypi/six/
+six:
+six: