summaryrefslogtreecommitdiffstats
path: root/python/stem
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2018-11-03 19:37:33 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-10 07:46:40 +0700
commit15698b3a49beb03ed7b31f417f699eef97ce5a71 (patch)
tree5ee40aefab46f27129312079b79da22fe8a8fbfd /python/stem
parent355da355e6667bd33b0e0364d2950f49b5a5f3f2 (diff)
downloadslackbuilds-15698b3a49beb03ed7b31f417f699eef97ce5a71.tar.gz
slackbuilds-15698b3a49beb03ed7b31f417f699eef97ce5a71.tar.xz
python/stem: Updated for version 1.7.0.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/stem')
-rw-r--r--python/stem/README4
-rw-r--r--python/stem/stem.SlackBuild20
-rw-r--r--python/stem/stem.info6
3 files changed, 10 insertions, 20 deletions
diff --git a/python/stem/README b/python/stem/README
index 3f5ce7d842..7156686e08 100644
--- a/python/stem/README
+++ b/python/stem/README
@@ -5,5 +5,5 @@ stem is compatible with python 2.6+ (including python 3)
Having Tor installed is not required for building.
The Tor installation does not have to be from SBo.
-Sphinx is an optional dependency to create proper documentation.
-In order to do so, pass DOC=yes to the script.
+A python 3 module will be compiled if python 3 is installed on
+the system during compile time.
diff --git a/python/stem/stem.SlackBuild b/python/stem/stem.SlackBuild
index f5824bec43..8cb95b59d5 100644
--- a/python/stem/stem.SlackBuild
+++ b/python/stem/stem.SlackBuild
@@ -24,7 +24,7 @@
# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=stem
-VERSION=${VERSION:-1.6.0}
+VERSION=${VERSION:-1.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
cd $TMP/$PRGNAM-$VERSION
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -81,20 +85,6 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-if [ "$DOC" = "yes" ]; then
- mkdir -p $PKG/usr/man/man1
- cd $TMP/$PRGNAM-$VERSION/docs
- make html
- make man
- cp -a _build/html $PKG/usr/doc/$PRGNAM-$VERSION
- rm $PKG/usr/doc/$PRGNAM-$VERSION/html/{.buildinfo,objects.inv}
- cp -a _build/man/* $PKG/usr/man/man1
- find $PKG/usr/man/man1 -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man1 -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- rm -rf $PKG/usr/doc/$PRGNAM-$VERSION/docs/*
- rmdir $PKG/usr/doc/$PRGNAM-$VERSION/docs
-fi;
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/stem/stem.info b/python/stem/stem.info
index 5584a067f0..fcdab24f0a 100644
--- a/python/stem/stem.info
+++ b/python/stem/stem.info
@@ -1,8 +1,8 @@
PRGNAM="stem"
-VERSION="1.6.0"
+VERSION="1.7.0"
HOMEPAGE="https://stem.torproject.org/"
-DOWNLOAD="https://pypi.python.org/packages/11/d5/e51983f81b38408ae2f0e166481ad867962f6fa07610fe71119534e12d41/stem-1.6.0.tar.gz"
-MD5SUM="fbf900e5c53441f7297b55154e3f34ea"
+DOWNLOAD="https://files.pythonhosted.org/packages/41/ed/3130c1c25819d70faac4a48308e01b0431c7244d56dd9b1870e32d55d902/stem-1.7.0.tar.gz"
+MD5SUM="15adb1ff309c49159b30482c070ad7a7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""