summaryrefslogtreecommitdiffstats
path: root/python/traceback2
diff options
context:
space:
mode:
author Nikos Giotis <nikos.giotis@gmail.com>2017-03-05 09:03:28 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-05 09:03:28 +0700
commit644dff6142b6ee1bbe4422b33231727317cdc62f (patch)
tree024bcfb6fb536273f17edaeea77d561bb5af36e9 /python/traceback2
parentb913e83a7b70177afb96037f08c21fcb91532e9f (diff)
downloadslackbuilds-644dff6142b6ee1bbe4422b33231727317cdc62f.tar.gz
slackbuilds-644dff6142b6ee1bbe4422b33231727317cdc62f.tar.xz
python/traceback2: Addded (Backports of the traceback module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/traceback2')
-rw-r--r--python/traceback2/README1
-rw-r--r--python/traceback2/slack-desc19
-rw-r--r--python/traceback2/traceback2.SlackBuild85
-rw-r--r--python/traceback2/traceback2.info10
4 files changed, 115 insertions, 0 deletions
diff --git a/python/traceback2/README b/python/traceback2/README
new file mode 100644
index 0000000000..fd3759393b
--- /dev/null
+++ b/python/traceback2/README
@@ -0,0 +1 @@
+A backport of traceback to older supported Pythons. \ No newline at end of file
diff --git a/python/traceback2/slack-desc b/python/traceback2/slack-desc
new file mode 100644
index 0000000000..a9258168d0
--- /dev/null
+++ b/python/traceback2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+traceback2: traceback2 (Backports of the traceback module)
+traceback2:
+traceback2: A backport of traceback to older supported Pythons.
+traceback2:
+traceback2: http://github.com/python-babel/traceback2
+traceback2:
+traceback2:
+traceback2:
+traceback2:
+traceback2:
+traceback2: \ No newline at end of file
diff --git a/python/traceback2/traceback2.SlackBuild b/python/traceback2/traceback2.SlackBuild
new file mode 100644
index 0000000000..1b99b6eb7e
--- /dev/null
+++ b/python/traceback2/traceback2.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for traceback2
+
+# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=traceback2
+VERSION=${VERSION:-1.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/traceback2/traceback2.info b/python/traceback2/traceback2.info
new file mode 100644
index 0000000000..98ca5e587e
--- /dev/null
+++ b/python/traceback2/traceback2.info
@@ -0,0 +1,10 @@
+PRGNAM="traceback2"
+VERSION="1.4.0"
+HOMEPAGE="https://github.com/testing-cabal/traceback2"
+DOWNLOAD="https://pypi.python.org/packages/eb/7f/e20ba11390bdfc55117c8c6070838ec914e6f0053a602390a598057884eb/traceback2-1.4.0.tar.gz"
+MD5SUM="9e9723f4d70bfc6308fa992dd193c400"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="linecache2"
+MAINTAINER="Nikos Giotis"
+EMAIL="nikos.giotis@gmail.com"