summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Janis Eisaks <jancs@dv.lv>2012-05-05 12:21:09 -0400
committer Erik Hanson <erik@slackbuilds.org>2012-05-07 12:18:08 -0500
commit2d41f5ec0ff540a6b326d2d06b38b7fc70aef5c0 (patch)
tree450e5ff75ea30d010e76788eaa126e3d2a17303c /python
parent6f8dd33bc840e28312843c48aa8eed66a435f696 (diff)
downloadslackbuilds-2d41f5ec0ff540a6b326d2d06b38b7fc70aef5c0.tar.gz
slackbuilds-2d41f5ec0ff540a6b326d2d06b38b7fc70aef5c0.tar.xz
python/python-Levenshtein: Added (string distance calculation)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-Levenshtein/README9
-rw-r--r--python/python-Levenshtein/python-Levenshtein.SlackBuild64
-rw-r--r--python/python-Levenshtein/python-Levenshtein.info10
-rw-r--r--python/python-Levenshtein/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/python/python-Levenshtein/README b/python/python-Levenshtein/README
new file mode 100644
index 0000000000..d931876c54
--- /dev/null
+++ b/python/python-Levenshtein/README
@@ -0,0 +1,9 @@
+Levenshtein Python extension and C library.
+
+The Levenshtein Python C extension module contains functions for fast
+computation of
+- Levenshtein (edit) distance, and edit operations
+- string similarity
+- approximate median strings, and generally string averaging
+- string sequence and set similarity
+It supports both normal and Unicode strings.
diff --git a/python/python-Levenshtein/python-Levenshtein.SlackBuild b/python/python-Levenshtein/python-Levenshtein.SlackBuild
new file mode 100644
index 0000000000..536c3305ec
--- /dev/null
+++ b/python/python-Levenshtein/python-Levenshtein.SlackBuild
@@ -0,0 +1,64 @@
+#!/bin/sh
+
+# Slackware build script for MySQL-python.
+
+# Written by Jick Nan (jick.nan@gmail.com)
+
+PRGNAM=python-Levenshtein
+VERSION=0.10.2
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.rst COPYING NEWS HISTORY.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-Levenshtein/python-Levenshtein.info b/python/python-Levenshtein/python-Levenshtein.info
new file mode 100644
index 0000000000..bf6c63b628
--- /dev/null
+++ b/python/python-Levenshtein/python-Levenshtein.info
@@ -0,0 +1,10 @@
+PRGNAM="python-Levenshtein"
+VERSION="0.10.2"
+HOMEPAGE="http://pypi.python.org/pypi/python-Levenshtein/"
+DOWNLOAD="http://pypi.python.org/packages/source/p/python-Levenshtein/python-Levenshtein-0.10.2.tar.gz"
+MD5SUM="c8af7296dc640abdf511614ee677bbb8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Janis Eisaks"
+EMAIL="jancs@dv.lv"
+APPROVED="dsomero"
diff --git a/python/python-Levenshtein/slack-desc b/python/python-Levenshtein/slack-desc
new file mode 100644
index 0000000000..90994ff7f9
--- /dev/null
+++ b/python/python-Levenshtein/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-Levenshtein: python-Levenshtein (string distance calculation module)
+python-Levenshtein:
+python-Levenshtein: python-levenhstein is a C extension module for Python that can be
+python-Levenshtein: used for fast calculation of string distances with the Levenshtein
+python-Levenshtein: algorithm, as well as some other methods.
+python-Levenshtein:
+python-Levenshtein: The python-Levenshtein website can be found at:
+python-Levenshtein: http://trific.ath.cx/resources/python/levenshtein/
+python-Levenshtein:
+python-Levenshtein:
+python-Levenshtein: