summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2015-12-31 07:51:29 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-12-31 07:51:29 +0700
commit2f1c1bf888f4e5664c96222d4cbfbb2eb2e4cc00 (patch)
tree3cf56ec62fd5c2ce8b9d8435e20304097d8a83c3 /python
parentfdcf49c91808b9cb514cfe243dbdeca1320e0b75 (diff)
downloadslackbuilds-2f1c1bf888f4e5664c96222d4cbfbb2eb2e4cc00.tar.gz
slackbuilds-2f1c1bf888f4e5664c96222d4cbfbb2eb2e4cc00.tar.xz
python/python-libnacl: Updated for version 1.4.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-libnacl/README7
-rw-r--r--python/python-libnacl/python-libnacl.SlackBuild12
-rw-r--r--python/python-libnacl/python-libnacl.info6
3 files changed, 16 insertions, 9 deletions
diff --git a/python/python-libnacl/README b/python/python-libnacl/README
index d856a07753..db7bea1cc8 100644
--- a/python/python-libnacl/README
+++ b/python/python-libnacl/README
@@ -1 +1,8 @@
Python bindings for libsodium/tweetnacl based on ctypes.
+
+Optional dependencies: msgpack-python and python3
+
+To install python3 bindings install python3 and then run the script
+with PYTHON3=yes.
+
+ # PYTHON3=yes ./python-libnacl.SlackBuild
diff --git a/python/python-libnacl/python-libnacl.SlackBuild b/python/python-libnacl/python-libnacl.SlackBuild
index 0e1a5769e7..9d8bf85b81 100644
--- a/python/python-libnacl/python-libnacl.SlackBuild
+++ b/python/python-libnacl/python-libnacl.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-libnacl
-# Copyright 2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2014-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-libnacl
SRCNAM=libnacl
-VERSION=${VERSION:-1.4.0}
+VERSION=${VERSION:-1.4.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,14 +65,14 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi
diff --git a/python/python-libnacl/python-libnacl.info b/python/python-libnacl/python-libnacl.info
index e65f50b03e..e3e42ee0b1 100644
--- a/python/python-libnacl/python-libnacl.info
+++ b/python/python-libnacl/python-libnacl.info
@@ -1,8 +1,8 @@
PRGNAM="python-libnacl"
-VERSION="1.4.0"
+VERSION="1.4.3"
HOMEPAGE="https://libnacl.readthedocs.org/en/latest/"
-DOWNLOAD="https://pypi.python.org/packages/source/l/libnacl/libnacl-1.4.0.tar.gz"
-MD5SUM="fd986449d9a2bf22ed9d05989bb46fba"
+DOWNLOAD="https://pypi.python.org/packages/source/l/libnacl/libnacl-1.4.3.tar.gz"
+MD5SUM="27f57f34ce6e0fe1dba7c754bd83773f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools libsodium"