summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Vincent Batts <vbatts@hashbangbash.com>2011-11-13 02:31:20 -0600
committer Robby Workman <rworkman@slackbuilds.org>2011-11-13 02:31:20 -0600
commit410a25438a2453d256596455d6285a531066b207 (patch)
tree98bd376170e9e69d2622131d774cb31a9b251c10 /python
parent7ac98e752dd60739b4de47cefdeb43299bfabdae (diff)
downloadslackbuilds-410a25438a2453d256596455d6285a531066b207.tar.gz
slackbuilds-410a25438a2453d256596455d6285a531066b207.tar.xz
python/google-api-python-client: Added (Google APIs Client for Python)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/google-api-python-client/README7
-rw-r--r--python/google-api-python-client/google-api-python-client.SlackBuild90
-rw-r--r--python/google-api-python-client/google-api-python-client.info10
-rw-r--r--python/google-api-python-client/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/google-api-python-client/README b/python/google-api-python-client/README
new file mode 100644
index 0000000000..136d714257
--- /dev/null
+++ b/python/google-api-python-client/README
@@ -0,0 +1,7 @@
+google-api-python-client (Google APIs Client for Python)
+
+Written by Google, this is a small, flexible, and powerful Python
+client library for accessing Google APIs. The library supports these
+Python environments: Google App Engine and Supported APIs
+This project is also the home of oauth2client, a Python client
+library for OAuth 2.0.
diff --git a/python/google-api-python-client/google-api-python-client.SlackBuild b/python/google-api-python-client/google-api-python-client.SlackBuild
new file mode 100644
index 0000000000..a2ed0ba3f5
--- /dev/null
+++ b/python/google-api-python-client/google-api-python-client.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for google-api-python-client
+
+# Copyright 2011 Vincent Batts, Vienna, VA. USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=google-api-python-client
+VERSION=${VERSION:-1.0beta2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README samples/ docs/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+find $PKG/usr/doc/$PRGNAM-$VERSION -type d -exec chmod 0755 {} \;
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/google-api-python-client/google-api-python-client.info b/python/google-api-python-client/google-api-python-client.info
new file mode 100644
index 0000000000..ce15b4904d
--- /dev/null
+++ b/python/google-api-python-client/google-api-python-client.info
@@ -0,0 +1,10 @@
+PRGNAM="google-api-python-client"
+VERSION="1.0beta2"
+HOMEPAGE="https://google-api-python-client.googlecode.com/"
+DOWNLOAD="http://google-api-python-client.googlecode.com/files/google-api-python-client-1.0beta2.tar.gz"
+MD5SUM="0998bcec19f69c7130a36d0c1a91b100"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Vincent Batts"
+EMAIL="vbatts@hashbangbash.com"
+APPROVED="rworkman"
diff --git a/python/google-api-python-client/slack-desc b/python/google-api-python-client/slack-desc
new file mode 100644
index 0000000000..181543017b
--- /dev/null
+++ b/python/google-api-python-client/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+google-api-python-client: google-api-python-client (Google APIs Client for Python)
+google-api-python-client:
+google-api-python-client: Written by Google, this is a small, flexible, and powerful Python
+google-api-python-client: client library for accessing Google APIs. The library supports these
+google-api-python-client: Python environments:
+google-api-python-client: Google App Engine
+google-api-python-client: Supported APIs
+google-api-python-client: This project is also the home of oauth2client, a Python client
+google-api-python-client: library for OAuth 2.0.
+google-api-python-client:
+google-api-python-client: