summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Bogdan Radulescu <bogdan@nimblex.net>2017-11-04 15:29:16 +0000
committer David Spencer <idlemoor@slackbuilds.org>2017-11-04 15:29:16 +0000
commit4a0fcde6c623f025c3ff5acbd6a7a7ea2124bc8b (patch)
treee8b7f9e3a6e671cf7f15f9bb7c16d3b16bbbfe2b /python
parent498dfb872721bcb343d921c9d33a6a1f6cca1575 (diff)
downloadslackbuilds-4a0fcde6c623f025c3ff5acbd6a7a7ea2124bc8b.tar.gz
slackbuilds-4a0fcde6c623f025c3ff5acbd6a7a7ea2124bc8b.tar.xz
python/pbr: Updated for version 3.1.1.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pbr/README24
-rw-r--r--python/pbr/pbr.SlackBuild18
-rw-r--r--python/pbr/pbr.info6
-rw-r--r--python/pbr/slack-desc2
4 files changed, 22 insertions, 28 deletions
diff --git a/python/pbr/README b/python/pbr/README
index 0b25866fe4..d7971dc442 100644
--- a/python/pbr/README
+++ b/python/pbr/README
@@ -1,16 +1,8 @@
-pbr (manage setuptools packaging)
-
-A library for managing setuptools packaging in a consistent manner.
-
-PBR is a library that injects some useful and sensible default behaviors
-into your setuptools run.
-
-PBR reads and then filters the setup.cfg data through a setup hook to
-fill in default values and provide more sensible behaviors, and then
-feeds the results in as the arguments to a call to setup.py
-
-PBR is only mildly configurable. The basic idea is that there's a decent
-way to run things and if you do, you should reap the rewards, because
-then it's simple and repeatable. If you want to do things differently,
-cool! But you've already got the power of python at your fingertips,
-so you don't really need PBR.
+PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run.
+
+PBR is only mildly configurable. The basic idea is that there's a
+decent way to run things and if you do, you should reap the rewards,
+because then it's simple and repeatable. If you want to do things
+differently, cool! But you've already got the power of python at your
+fingertips, so you don't really need PBR.
diff --git a/python/pbr/pbr.SlackBuild b/python/pbr/pbr.SlackBuild
index 6424e632c9..b0165bd457 100644
--- a/python/pbr/pbr.SlackBuild
+++ b/python/pbr/pbr.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pbr
-VERSION=${VERSION:-1.8.1}
+VERSION=${VERSION:-3.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,15 +67,17 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS ChangeLog PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pbr/pbr.info b/python/pbr/pbr.info
index a79fd3acee..28478b1320 100644
--- a/python/pbr/pbr.info
+++ b/python/pbr/pbr.info
@@ -1,8 +1,8 @@
PRGNAM="pbr"
-VERSION="1.8.1"
+VERSION="3.1.1"
HOMEPAGE="https://pypi.python.org/pypi/pbr"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pbr/pbr-1.8.1.tar.gz"
-MD5SUM="c8f9285e1a4ca6f9654c529b158baa3a"
+DOWNLOAD="https://pypi.python.org/packages/d5/d6/f2bf137d71e4f213b575faa9eb426a8775732432edb67588a8ee836ecb80/pbr-3.1.1.tar.gz"
+MD5SUM="4e82c2e07af544c56a5b71c801525b00"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/pbr/slack-desc b/python/pbr/slack-desc
index e3f4ad8215..ead08d3dbe 100644
--- a/python/pbr/slack-desc
+++ b/python/pbr/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-pbr: pbr (manage setuptools packaging)
+pbr: pbr (managing setuptools packaging in python)
pbr:
pbr: A library for managing setuptools packaging in a consistent manner.
pbr: