summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-04-09 09:37:48 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-09 09:41:49 +0700
commit6e118364df72ef162554a75c6432b7de1b9fcb86 (patch)
tree694ac392e49cb64a0dfa33e477c0e8c57489b074 /python
parent9e2a149a6a37dcfe957f1dab3accf25c242bd675 (diff)
downloadslackbuilds-6e118364df72ef162554a75c6432b7de1b9fcb86.tar.gz
slackbuilds-6e118364df72ef162554a75c6432b7de1b9fcb86.tar.xz
python/simplegeneric: Updated for version 0.8.1 (moved from libs).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/simplegeneric/README5
-rw-r--r--python/simplegeneric/simplegeneric.SlackBuild74
-rw-r--r--python/simplegeneric/simplegeneric.info10
-rw-r--r--python/simplegeneric/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/simplegeneric/README b/python/simplegeneric/README
new file mode 100644
index 0000000000..e18377fb96
--- /dev/null
+++ b/python/simplegeneric/README
@@ -0,0 +1,5 @@
+The simplegeneric module lets you define simple single-dispatch
+generic functions, akin to Python's built-in generic functions like
+len(), iter() and so on.
+
+Python 3 support will be included if python3 is installed.
diff --git a/python/simplegeneric/simplegeneric.SlackBuild b/python/simplegeneric/simplegeneric.SlackBuild
new file mode 100644
index 0000000000..583ea51528
--- /dev/null
+++ b/python/simplegeneric/simplegeneric.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for simplegeneric
+
+# Copyright 2012 Mikko Värri, Finland
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=simplegeneric
+VERSION=${VERSION:-0.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/simplegeneric/simplegeneric.info b/python/simplegeneric/simplegeneric.info
new file mode 100644
index 0000000000..aad9325d38
--- /dev/null
+++ b/python/simplegeneric/simplegeneric.info
@@ -0,0 +1,10 @@
+PRGNAM="simplegeneric"
+VERSION="0.8.1"
+HOMEPAGE="http://pypi.python.org/pypi/simplegeneric"
+DOWNLOAD="http://pypi.python.org/packages/source/s/simplegeneric/simplegeneric-0.8.1.zip"
+MD5SUM="f9c1fab00fd981be588fc32759f474e3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/simplegeneric/slack-desc b/python/simplegeneric/slack-desc
new file mode 100644
index 0000000000..bbc352eb13
--- /dev/null
+++ b/python/simplegeneric/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+simplegeneric: simplegeneric (Simple generic functions)
+simplegeneric:
+simplegeneric: The simplegeneric module lets you define simple single-dispatch
+simplegeneric: generic functions, akin to Python's built-in generic functions like
+simplegeneric: len(), iter() and so on.
+simplegeneric:
+simplegeneric:
+simplegeneric:
+simplegeneric:
+simplegeneric:
+simplegeneric: