summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2018-02-10 18:01:09 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-02-17 07:43:02 +0700
commit78abd5f7799e7288fc6102a7a711272b5e845c6f (patch)
tree9535b82c41fdd38ad235f8cf5a8ab7f5cfa71cae /python
parent01fbc933dca87d201b31a1eaff18a8878319dd64 (diff)
downloadslackbuilds-78abd5f7799e7288fc6102a7a711272b5e845c6f.tar.gz
slackbuilds-78abd5f7799e7288fc6102a7a711272b5e845c6f.tar.xz
python/typing: Updated for version 3.6.4.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/typing/README2
-rw-r--r--python/typing/typing.SlackBuild9
-rw-r--r--python/typing/typing.info6
3 files changed, 12 insertions, 5 deletions
diff --git a/python/typing/README b/python/typing/README
index 21502e4a6f..471488acff 100644
--- a/python/typing/README
+++ b/python/typing/README
@@ -1,2 +1,4 @@
This is a backport of the standard library typing module to Python
versions older than 3.5.
+
+python3 is an optional dependency (autodetected).
diff --git a/python/typing/typing.SlackBuild b/python/typing/typing.SlackBuild
index 741b819fbd..fc6e681e9c 100644
--- a/python/typing/typing.SlackBuild
+++ b/python/typing/typing.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for typing
-# Copyright 2016-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=typing
-VERSION=${VERSION:-3.6.2}
+VERSION=${VERSION:-3.6.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/typing/typing.info b/python/typing/typing.info
index a45f142657..fd6712f4c9 100644
--- a/python/typing/typing.info
+++ b/python/typing/typing.info
@@ -1,8 +1,8 @@
PRGNAM="typing"
-VERSION="3.6.2"
+VERSION="3.6.4"
HOMEPAGE="https://docs.python.org/3.5/library/typing.html"
-DOWNLOAD="https://pypi.python.org/packages/ca/38/16ba8d542e609997fdcd0214628421c971f8c395084085354b11ff4ac9c3/typing-3.6.2.tar.gz"
-MD5SUM="143af0bf3afd1887622771f2f1ffe8e1"
+DOWNLOAD="https://pypi.python.org/packages/ec/cc/28444132a25c113149cec54618abc909596f0b272a74c55bab9593f8876c/typing-3.6.4.tar.gz"
+MD5SUM="5b2ade08d83be488f17b5fe587c27c74"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""