summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Hunter Sezen <orbea@fredslev.dk>2018-03-15 21:01:45 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-17 08:51:49 +0700
commit9d0aa2e4ae70204b7adab248c718efec007ad43c (patch)
tree4cbbe262d17d51714377cb2d207da78f844455c0 /python
parent0cd6e1cb06f9cf541e98798e5357bf7b7c27ea60 (diff)
downloadslackbuilds-9d0aa2e4ae70204b7adab248c718efec007ad43c.tar.gz
slackbuilds-9d0aa2e4ae70204b7adab248c718efec007ad43c.tar.xz
python/python-xlib: Updated for version 0.21 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-xlib/README21
-rw-r--r--python/python-xlib/python-xlib.SlackBuild30
-rw-r--r--python/python-xlib/python-xlib.info14
-rw-r--r--python/python-xlib/setup.patch.gzbin0 -> 685 bytes
-rw-r--r--python/python-xlib/slack-desc16
5 files changed, 51 insertions, 30 deletions
diff --git a/python/python-xlib/README b/python/python-xlib/README
index 49962b13a9..0f8c15d1ee 100644
--- a/python/python-xlib/README
+++ b/python/python-xlib/README
@@ -1,6 +1,17 @@
-The Python X library is intended to be a fully functional X client for Python
-programs. It is written entirely in Python, in ontrast to earlier X libraries
-for Python. This is possible to do since X client programs communicate with
-the X server via the X protocol. The communication takes over TCP/IP, Unix
-sockets, or any other streaming network protocol.
+The Python X Library is intended to be a fully functional X client
+library for Python programs. It is written entirely in Python, in
+contrast to earlier X libraries for Python which were interfaces to
+the C Xlib.
+This is possible to do since X client programs communicate with the X
+server via the X protocol. The communication takes place over TCP/IP,
+Unix sockets, DECnet or any other streaming network protocol. The C
+Xlib is merely an interface to this protocol, providing functions
+suitable for a C environment.
+
+Python3 is an optional dependency and python3-six is required if built
+with python3 support.
+
+setuptools-scm is only required as a build dependency and can be
+skipped if you would rather have it automatically grabbed from
+pypi.python.org during the build process.
diff --git a/python/python-xlib/python-xlib.SlackBuild b/python/python-xlib/python-xlib.SlackBuild
index a5dd319029..341666f5ee 100644
--- a/python/python-xlib/python-xlib.SlackBuild
+++ b/python/python-xlib/python-xlib.SlackBuild
@@ -1,12 +1,12 @@
#!/bin/sh
# Slackware build script for python-xlib
-# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
-# Modified by the SlackBuilds.org project
+# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
+# Copyright 2018 Hunter Sezen California, USA
PRGNAM=python-xlib
-VERSION=${VERSION:-0.14}
+VERSION=${VERSION:-0.21}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -23,25 +23,35 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="COPYING NEWS PKG-INFO README TODO"
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
-cd $PRGNAM-$VERSION || exit 1
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Partially revert: fixup metadata
+# https://github.com/python-xlib/python-xlib/commit/22a8e1929ad58b8168bcf5d931e8f6067ebdec0a
+# https://github.com/python-xlib/python-xlib/issues/106
+zcat $CWD/setup.patch.gz | patch -R -p1
-python setup.py install --root $PKG || exit 1
+python setup.py install --root $PKG
+
+# Python 3 support.
+if python3 -c 'import sys' 2>/dev/null; then
+ python3 setup.py install --root=$PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md LICENSE PKG-INFO README.rst TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-xlib/python-xlib.info b/python/python-xlib/python-xlib.info
index 1bde19e864..cf7eec970b 100644
--- a/python/python-xlib/python-xlib.info
+++ b/python/python-xlib/python-xlib.info
@@ -1,10 +1,10 @@
PRGNAM="python-xlib"
-VERSION="0.14"
-HOMEPAGE="http://python-xlib.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/python-xlib/python-xlib-0.14.tar.gz"
-MD5SUM="a038c2f410d8445f3fa8f6dcd45659c5"
+VERSION="0.21"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+DOWNLOAD="https://github.com/python-xlib/python-xlib/releases/download/0.21/python-xlib-0.21.tar.bz2"
+MD5SUM="cdf342aa145c2be0ccae46cfb7b62551"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Vasilis Papavasileiou"
-EMAIL="el03020@mail.ntua.gr"
+REQUIRES="setuptools-scm six"
+MAINTAINER="Hunter Sezen"
+EMAIL="orbea@fredslev.dk"
diff --git a/python/python-xlib/setup.patch.gz b/python/python-xlib/setup.patch.gz
new file mode 100644
index 0000000000..8626ec1a79
--- /dev/null
+++ b/python/python-xlib/setup.patch.gz
Binary files differ
diff --git a/python/python-xlib/slack-desc b/python/python-xlib/slack-desc
index bc463e25a8..1a2c266df7 100644
--- a/python/python-xlib/slack-desc
+++ b/python/python-xlib/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
python-xlib: python-xlib (X Library module for Python)
python-xlib:
-python-xlib: The Python X library is intended to be a fully functional X
-python-xlib: client for Python programs. It is written entirely in Python, in
-python-xlib: contrast to earlier X libraries for Python. This is possible to
-python-xlib: do since X client programs communicate with the X server via the
-python-xlib: X protocol. The communication takes over TCP/IP, Unix sockets, or
-python-xlib: any other streaming network protocol.
-python-xlib:
-python-xlib: Homepage: http://python-xlib.sourceforge.net/
+python-xlib: The Python X Library is intended to be a fully functional X client
+python-xlib: library for Python programs. It is written entirely in Python, in
+python-xlib: contrast to earlier X libraries for Python which were interfaces to
+python-xlib: the C Xlib. The communication takes place over TCP/IP, Unix sockets,
+python-xlib: DECnet or any other streaming network protocol. The C Xlib is merely
+python-xlib: an interface to this protocol, providing functions suitable for a C
+python-xlib: environment.
python-xlib:
+python-xlib: Homepage: https://github.com/python-xlib/python-xlib