summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Yth - Arnaud <yth@ythogtha.org>2019-10-23 23:10:04 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-10-23 23:10:04 +0700
commita2591c7b95bae39f1f75ba251b9a8bbf919d3d5a (patch)
tree3dc9c6816a9efa64ffc218cb790bc383d6b1c14b /python
parentd600a9d210c68012fc6912df37b641ae0f0bf574 (diff)
downloadslackbuilds-a2591c7b95bae39f1f75ba251b9a8bbf919d3d5a.tar.gz
slackbuilds-a2591c7b95bae39f1f75ba251b9a8bbf919d3d5a.tar.xz
python/URLObject: Added (utility class for manipulating URLs).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/URLObject/README5
-rw-r--r--python/URLObject/URLObject.SlackBuild69
-rw-r--r--python/URLObject/URLObject.info10
-rw-r--r--python/URLObject/slack-desc19
4 files changed, 103 insertions, 0 deletions
diff --git a/python/URLObject/README b/python/URLObject/README
new file mode 100644
index 0000000000..cc6220c9fb
--- /dev/null
+++ b/python/URLObject/README
@@ -0,0 +1,5 @@
+URLObject is a utility class for manipulating URLs.
+The latest incarnation of this library builds upon the ideas of its predecessor,
+but aims for a clearer API, focusing on proper method names over operator overrides.
+It's also being developed from the ground up in a test-driven manner,
+and has full Sphinx documentation.
diff --git a/python/URLObject/URLObject.SlackBuild b/python/URLObject/URLObject.SlackBuild
new file mode 100644
index 0000000000..291a0e67db
--- /dev/null
+++ b/python/URLObject/URLObject.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# SlackBuild script for URLObject.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=URLObject
+VERSION=${VERSION:-2.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/URLObject/URLObject.info b/python/URLObject/URLObject.info
new file mode 100644
index 0000000000..a4cc180092
--- /dev/null
+++ b/python/URLObject/URLObject.info
@@ -0,0 +1,10 @@
+PRGNAM="URLObject"
+VERSION="2.4.3"
+HOMEPAGE="http://github.com/zacharyvoase/urlobject"
+DOWNLOAD="https://pypi.python.org/packages/source/U/URLObject/URLObject-2.4.3.tar.gz"
+MD5SUM="bbce110483eda19da3008f929d02dc98"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/URLObject/slack-desc b/python/URLObject/slack-desc
new file mode 100644
index 0000000000..d0a65ba786
--- /dev/null
+++ b/python/URLObject/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+URLObject: URLObject (utility class for manipulating URLs)
+URLObject:
+URLObject: The latest incarnation of this library builds upon the ideas of its
+URLObject: predecessor, but aims for a clearer API, focusing on proper method
+URLObject: names over operator overrides.
+URLObject:
+URLObject: It's also being developed from the ground up in a test-driven manner,
+URLObject: and has full Sphinx documentation.
+URLObject:
+URLObject:
+URLObject: