summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author larryhaja <larryhaja@gmail.com>2013-11-13 19:15:55 -0800
committer Robby Workman <rworkman@slackbuilds.org>2013-11-14 00:06:28 -0600
commitb4c4309118001ece8f999b4d60b9172332a29cfa (patch)
tree71813dfaea192eac1632aedba051ffe25f652788 /python
parent678dc5fb20d5dabbef80f2b7ce07d00a263d8ee9 (diff)
downloadslackbuilds-b4c4309118001ece8f999b4d60b9172332a29cfa.tar.gz
slackbuilds-b4c4309118001ece8f999b4d60b9172332a29cfa.tar.xz
python/cssselect: Upgraded to 0.9.1
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/cssselect/README3
-rw-r--r--python/cssselect/cssselect.SlackBuild3
-rw-r--r--python/cssselect/cssselect.info8
3 files changed, 8 insertions, 6 deletions
diff --git a/python/cssselect/README b/python/cssselect/README
index 9d2c7d4aae..b96802a664 100644
--- a/python/cssselect/README
+++ b/python/cssselect/README
@@ -3,4 +3,5 @@ Such expressions can be used in lxml or another XPath engine to find the
matching elements in an XML or HTML document.
Optionally: lxml can be installed for running tests. Sphinx and Pygments
-can be installed for man pages.
+can be installed for man pages. pysetuptools can be used as a build time
+dependency.
diff --git a/python/cssselect/cssselect.SlackBuild b/python/cssselect/cssselect.SlackBuild
index c7ef13b66c..a96badfb3a 100644
--- a/python/cssselect/cssselect.SlackBuild
+++ b/python/cssselect/cssselect.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cssselect
-VERSION=${VERSION:-0.8}
+VERSION=${VERSION:-0.9.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -79,6 +79,7 @@ if python -c 'import sphinx.pygments_styles' 2>/dev/null; then
python setup.py build_sphinx -b man
install -D -m 0644 docs/_build/man/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
+ rm -rf docs/_build
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/cssselect/cssselect.info b/python/cssselect/cssselect.info
index 359d4ecd06..558bd66e6c 100644
--- a/python/cssselect/cssselect.info
+++ b/python/cssselect/cssselect.info
@@ -1,10 +1,10 @@
PRGNAM="cssselect"
-VERSION="0.8"
+VERSION="0.9.1"
HOMEPAGE="http://packages.python.org/cssselect/"
-DOWNLOAD="http://pypi.python.org/packages/source/c/cssselect/cssselect-0.8.tar.gz"
-MD5SUM="c4683e050351abcbbd5990b01f5344e2"
+DOWNLOAD="http://pypi.python.org/packages/source/c/cssselect/cssselect-0.9.1.tar.gz"
+MD5SUM="c74f45966277dc7a0f768b9b0f3522ac"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
+REQUIRES="%README%"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"