summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundyat>2019-01-13 10:50:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-01-13 22:12:27 +0700
commitc11ac71aa831d38354d72264c2972f8c7c2a96f2 (patch)
treecfc2d441609d1b7eac187258db1bdb16f8ac5bbc /python
parentf6b196dbd1c0588dfa36ae5b24afa30ac6eccfbb (diff)
downloadslackbuilds-c11ac71aa831d38354d72264c2972f8c7c2a96f2.tar.gz
slackbuilds-c11ac71aa831d38354d72264c2972f8c7c2a96f2.tar.xz
python/biplist: Added (plist parser/generator module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/biplist/README8
-rw-r--r--python/biplist/biplist.SlackBuild85
-rw-r--r--python/biplist/biplist.info10
-rw-r--r--python/biplist/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/biplist/README b/python/biplist/README
new file mode 100644
index 0000000000..89ddbb3b86
--- /dev/null
+++ b/python/biplist/README
@@ -0,0 +1,8 @@
+biplist is a binary plist parser/generator for Python.
+
+Binary Property List (plist) files provide a faster and smaller serialization
+format for property lists on OS X. This is a library for generating binary
+plists which can be read by OS X, iOS, or other clients.
+
+This module requires Python 2.6 or higher or Python 3.4 or higher.
+binary property list (plist) parser module written in python.
diff --git a/python/biplist/biplist.SlackBuild b/python/biplist/biplist.SlackBuild
new file mode 100644
index 0000000000..5146f74318
--- /dev/null
+++ b/python/biplist/biplist.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for binplist
+# Copyright 2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial Build - January 2019 by Barry J. Grundy
+
+PRGNAM=biplist
+VERSION=${VERSION:-1.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/biplist/biplist.info b/python/biplist/biplist.info
new file mode 100644
index 0000000000..de1f55049a
--- /dev/null
+++ b/python/biplist/biplist.info
@@ -0,0 +1,10 @@
+PRGNAM="biplist"
+VERSION="1.0.3"
+HOMEPAGE="https://pypi.org/project/biplist/"
+DOWNLOAD="https://files.pythonhosted.org/packages/3e/56/2db170a498c9c6545cda16e93c2f2ef9302da44802787b45a8a520d01bdb/biplist-1.0.3.tar.gz"
+MD5SUM="e2ff83d5f66e5798801d142eb7c1a07a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/biplist/slack-desc b/python/biplist/slack-desc
new file mode 100644
index 0000000000..4b68d9ba08
--- /dev/null
+++ b/python/biplist/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+biplist: biplist (plist parser/generator module)
+biplist:
+biplist: Binary Property List (plist) files provide a faster and smaller
+biplist: serialization format for property lists on OS X. This is a library
+biplist: for generating binary plists which can be read by OS X, iOS, or
+biplist: other clients.
+biplist:
+biplist: https://pypi.org/project/biplist/
+biplist:
+biplist:
+biplist: