summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2020-04-21 14:12:02 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-04-24 08:19:00 +0700
commitf816ab506a076507c80d60faf64a3f3ea6ee8b8a (patch)
tree7abb7763ee854e6d19d5240a4868a01e1d06739a /python
parent3cf15abede4519a4341fd66363b477643cc04bca (diff)
downloadslackbuilds-f816ab506a076507c80d60faf64a3f3ea6ee8b8a.tar.gz
slackbuilds-f816ab506a076507c80d60faf64a3f3ea6ee8b8a.tar.xz
python/pytables: Removed (abandoned and not compatible with hdf5).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pytables/README17
-rw-r--r--python/pytables/pytables.SlackBuild98
-rw-r--r--python/pytables/pytables.info10
-rw-r--r--python/pytables/slack-desc19
4 files changed, 0 insertions, 144 deletions
diff --git a/python/pytables/README b/python/pytables/README
deleted file mode 100644
index 4790b2fb90..0000000000
--- a/python/pytables/README
+++ /dev/null
@@ -1,17 +0,0 @@
-PyTables is a package for managing hierarchical datasets
-and designed to efficiently and easily cope with extremely
-large amounts of data. It optimizes memory and disk resources
-so that data takes much less space than other solutions such
-as relational or object oriented databases.
-
-PyTables has been designed to fulfill the next requirements:
- 1. Allow to structure your data in a hierarchical way.
- 2. Easy to use. It implements the NaturalNaming scheme for
- allowing convenient access to the data.
- 3. All the cells in datasets can be multidimensional entities.
- 4. Most of the I/O operations speed should be only limited by
- the underlying I/O subsystem.
- 5. Enable the end user to save large datasets in a efficient
- way, i.e. each single byte of data on disk has to be
- represented by one byte plus a small fraction when loaded
- in memory.
diff --git a/python/pytables/pytables.SlackBuild b/python/pytables/pytables.SlackBuild
deleted file mode 100644
index 08f02e5c9b..0000000000
--- a/python/pytables/pytables.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pytables
-
-# Copyright 2007-2015 LukenShiro, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pytables
-VERSION=${VERSION:-3.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-SRC_PRGNAM=tables
-DOCFILES="ANNOUNCE.txt LICENSE.txt LICENSES/ PKG-INFO README.rst \
- RELEASE_NOTES.txt THANKS doc/html doc/scripts"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRC_PRGNAM-$VERSION
-tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
-cd $SRC_PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Fix compilation with Cython 0.21
-# https://github.com/PyTables/PyTables/issues/386
-sed -i "s|Cython.Compiler.Main import|Cython.Compiler import|g" setup.py
-
-python setup.py build install --prefix=/usr --root=$PKG
-
-# Copy examples, contrib, and bench files
-mkdir -p $PKG/usr/share/$PRGNAM/
-cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
-
-# Copy documentation files
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pytables/pytables.info b/python/pytables/pytables.info
deleted file mode 100644
index cdfbface7d..0000000000
--- a/python/pytables/pytables.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pytables"
-VERSION="3.2.0"
-HOMEPAGE="http://www.pytables.org"
-DOWNLOAD="http://downloads.sourceforge.net/pytables/tables-3.2.0.tar.gz"
-MD5SUM="339a2225ee814a6899cb14e7ba28c081"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="hdf5 numexpr"
-MAINTAINER="LukenShiro"
-EMAIL="lukenshiro@ngi.it"
diff --git a/python/pytables/slack-desc b/python/pytables/slack-desc
deleted file mode 100644
index 1eb3e8f8ce..0000000000
--- a/python/pytables/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pytables: pytables (Hierarchical datasets in Python)
-pytables:
-pytables: PyTables is a package for managing hierarchical datasets and
-pytables: designed to efficiently and easily cope with extremely large amounts
-pytables: of data. It optimizes memory and disk resources so that data takes
-pytables: much less space than other solutions such as relational or object
-pytables: oriented databases.
-pytables:
-pytables: Homepage: http://www.pytables.org/moin
-pytables:
-pytables: