summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2011-03-30 00:11:16 +0200
committer Robby Workman <rworkman@slackbuilds.org>2011-03-30 22:52:57 -0500
commitf8fceb6eaf3a45e6df24b1dbe6445334042634f1 (patch)
tree7c92cd6c9b24c5927428c0bc0147ac85c0ee639a /python
parent9fb2b1a1191ae5fc50df9f218cb0c82db4dbe43b (diff)
downloadslackbuilds-f8fceb6eaf3a45e6df24b1dbe6445334042634f1.tar.gz
slackbuilds-f8fceb6eaf3a45e6df24b1dbe6445334042634f1.tar.xz
python/paramiko: Moved from /development + updated download link
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/paramiko/README8
-rw-r--r--python/paramiko/paramiko.SlackBuild71
-rw-r--r--python/paramiko/paramiko.info10
-rw-r--r--python/paramiko/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/paramiko/README b/python/paramiko/README
new file mode 100644
index 0000000000..eef918b850
--- /dev/null
+++ b/python/paramiko/README
@@ -0,0 +1,8 @@
+"paramiko" is a combination of the esperanto words for "paranoid"
+and "friend". it's a module for python 2.2+ that implements the
+SSH2 protocol for secure (encrypted and authenticated) connections
+to remote machines. Unlike SSL (aka TLS), SSH2 protocol does not
+require heirarchical certificates signed by a powerful central
+authority.
+
+paramiko requires pycrypto, also available from Slackbuilds.org
diff --git a/python/paramiko/paramiko.SlackBuild b/python/paramiko/paramiko.SlackBuild
new file mode 100644
index 0000000000..c1a9ef1302
--- /dev/null
+++ b/python/paramiko/paramiko.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for paramiko
+
+# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=paramiko
+VERSION=1.7.6
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/paramiko/paramiko.info b/python/paramiko/paramiko.info
new file mode 100644
index 0000000000..2bc7bfdf66
--- /dev/null
+++ b/python/paramiko/paramiko.info
@@ -0,0 +1,10 @@
+PRGNAM="paramiko"
+VERSION="1.7.6"
+HOMEPAGE="http://www.lag.net/paramiko/"
+DOWNLOAD="http://www.liwjatan.at/files/src/paramiko-1.7.6.tar.gz"
+MD5SUM="fa144ab46f1dc639b05ab948c30efac4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@liwjatan.at"
+APPROVED="Erik Hanson"
diff --git a/python/paramiko/slack-desc b/python/paramiko/slack-desc
new file mode 100644
index 0000000000..678e91a37c
--- /dev/null
+++ b/python/paramiko/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------------|
+paramiko: paramiko (Python SSH module)
+paramiko:
+paramiko: "paramiko" is a combination of the esperanto words for "paranoid"
+paramiko: and "friend". it's a module for python 2.2+ that implements the
+paramiko: SSH2 protocol for secure (encrypted and authenticated) connections
+paramiko: to remote machines. Unlike SSL (aka TLS), SSH2 protocol does not
+paramiko: require heirarchical certificates signed by a powerful central
+paramiko: authority.
+paramiko:
+paramiko: Homepage: http://www.lag.net/paramiko/
+paramiko: