summaryrefslogtreecommitdiffstats
path: root/system/ZoneMinder
diff options
context:
space:
mode:
author ponce <matteo.bernardini@gmail.com>2012-06-21 09:57:44 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-08-21 08:55:25 -0500
commit5cb21d9d1c0773ee292cbbd60146e0f9cd88883c (patch)
tree15ad0cd1dfecf80e3474f194113908f7919e8fc4 /system/ZoneMinder
parent114838e4dfcae0446df1644631bccd2437dcf27a (diff)
downloadslackbuilds-5cb21d9d1c0773ee292cbbd60146e0f9cd88883c.tar.gz
slackbuilds-5cb21d9d1c0773ee292cbbd60146e0f9cd88883c.tar.xz
system/ZoneMinder: Updated to svn revision r3649
This commit also added a patch for gcc-4.7 and removed others. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system/ZoneMinder')
-rw-r--r--system/ZoneMinder/ZoneMinder.SlackBuild6
-rw-r--r--system/ZoneMinder/ZoneMinder.info14
-rw-r--r--system/ZoneMinder/patches/01_gcc_4.7.patch55
-rw-r--r--system/ZoneMinder/patches/02_destdir-fix.patch19
-rw-r--r--system/ZoneMinder/patches/03_libjpegv8.patch50
-rw-r--r--system/ZoneMinder/patches/04_streaming-update.patch39
-rw-r--r--system/ZoneMinder/patches/zm_build_fix.patch11
-rw-r--r--system/ZoneMinder/patches/zm_create.sql.in.patch28
8 files changed, 76 insertions, 146 deletions
diff --git a/system/ZoneMinder/ZoneMinder.SlackBuild b/system/ZoneMinder/ZoneMinder.SlackBuild
index 39bc1cf870..0c25b6e4a3 100644
--- a/system/ZoneMinder/ZoneMinder.SlackBuild
+++ b/system/ZoneMinder/ZoneMinder.SlackBuild
@@ -25,7 +25,7 @@
# Heavily modified by the SlackBuilds.org project 2010 --dsomero
PRGNAM=ZoneMinder
-VERSION=${VERSION:-1.24.2}
+VERSION=${VERSION:-r3649}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -156,6 +156,9 @@ cp -Rp jscalendar-$JSCALENDAR_VERSION/* $PKG$DOCROOT/tools/jscalendar
mkdir -p $PKG/usr/share/$PRGNAM/db
cp -a db/zm_create.sql db/zm_update-*.sql $PKG/usr/share/$PRGNAM/db
+# Remove other dangerous junk
+rm -fR $PKG/tmp
+
# Copy documentation
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog INSTALL NEWS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
@@ -163,7 +166,6 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
cat $CWD/README.PERLDEPS > $PKG/usr/doc/$PRGNAM-$VERSION/README.PERLDEPS
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff --git a/system/ZoneMinder/ZoneMinder.info b/system/ZoneMinder/ZoneMinder.info
index c5a354eb99..daf356470f 100644
--- a/system/ZoneMinder/ZoneMinder.info
+++ b/system/ZoneMinder/ZoneMinder.info
@@ -1,12 +1,12 @@
PRGNAM="ZoneMinder"
-VERSION="1.24.2"
+VERSION="r3649"
HOMEPAGE="http://www.zoneminder.com"
-DOWNLOAD="http://www2.zoneminder.com/downloads/ZoneMinder-1.24.2.tar.gz \
- http://www.charliemouse.com:8080/code/cambozola/cambozola-0.76.tar.gz \
- http://downloads.sourceforge.net/jscalendar/jscalendar-1.0.zip"
-MD5SUM="550d2f8f08852134028c3b1cf8fa437f \
- 30c17059bbba8da69bb971b4082eb712 \
- 10f2160fe68294013efcd1473cd36f72"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/ZoneMinder-r3649.tar.gz \
+ http://www.charliemouse.com:8080/code/cambozola/cambozola-0.76.tar.gz \
+ http://downloads.sourceforge.net/jscalendar/jscalendar-1.0.zip"
+MD5SUM="a761d0355bcf8427b403791aa616b434 \
+ 30c17059bbba8da69bb971b4082eb712 \
+ 10f2160fe68294013efcd1473cd36f72"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="ffmpeg libwww-perl perl-Archive-Zip perl-Date-Manip perl-Device-SerialPort perl-MIME-Lite perl-PHP-Serialization perl-Sys-Mmap perl-X10"
diff --git a/system/ZoneMinder/patches/01_gcc_4.7.patch b/system/ZoneMinder/patches/01_gcc_4.7.patch
new file mode 100644
index 0000000000..9678661e9c
--- /dev/null
+++ b/system/ZoneMinder/patches/01_gcc_4.7.patch
@@ -0,0 +1,55 @@
+diff -Naur ZoneMinder-r3649.orig/src/zm_logger.cpp ZoneMinder-r3649/src/zm_logger.cpp
+--- ZoneMinder-r3649.orig/src/zm_logger.cpp 2011-06-28 13:07:35.197263000 +0200
++++ ZoneMinder-r3649/src/zm_logger.cpp 2012-06-20 15:00:53.054661523 +0200
+@@ -22,6 +22,7 @@
+ #include "zm_config.h"
+ #include "zm_utils.h"
+
++#include <unistd.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+diff -Naur ZoneMinder-r3649.orig/src/zm_rtp_data.cpp ZoneMinder-r3649/src/zm_rtp_data.cpp
+--- ZoneMinder-r3649.orig/src/zm_rtp_data.cpp 2010-11-11 13:22:35.884567000 +0100
++++ ZoneMinder-r3649/src/zm_rtp_data.cpp 2012-06-20 15:05:36.466118392 +0200
+@@ -17,6 +17,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ //
+
++#include <unistd.h>
+ #include "zm.h"
+
+ #if HAVE_LIBAVFORMAT
+diff -Naur ZoneMinder-r3649.orig/src/zm_rtp_source.cpp ZoneMinder-r3649/src/zm_rtp_source.cpp
+--- ZoneMinder-r3649.orig/src/zm_rtp_source.cpp 2010-07-04 20:00:35.480475000 +0200
++++ ZoneMinder-r3649/src/zm_rtp_source.cpp 2012-06-20 15:05:26.907237894 +0200
+@@ -17,6 +17,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ //
+
++#include <unistd.h>
+ #include "zm_rtp_source.h"
+
+ #include "zm_time.h"
+diff -Naur ZoneMinder-r3649.orig/src/zm_thread.cpp ZoneMinder-r3649/src/zm_thread.cpp
+--- ZoneMinder-r3649.orig/src/zm_thread.cpp 2011-06-21 11:19:10.272416000 +0200
++++ ZoneMinder-r3649/src/zm_thread.cpp 2012-06-20 15:06:50.786189262 +0200
+@@ -17,6 +17,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ //
+
++#include <unistd.h>
+ #include "zm_thread.h"
+
+ #include "zm_logger.h"
+diff -Naur ZoneMinder-r3649.orig/src/zm_timer.cpp ZoneMinder-r3649/src/zm_timer.cpp
+--- ZoneMinder-r3649.orig/src/zm_timer.cpp 2011-06-21 11:19:10.272416000 +0200
++++ ZoneMinder-r3649/src/zm_timer.cpp 2012-06-20 15:07:44.437518529 +0200
+@@ -17,6 +17,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ //
+
++#include <unistd.h>
+ #include "zm_timer.h"
+
+ #include "zm_logger.h"
diff --git a/system/ZoneMinder/patches/02_destdir-fix.patch b/system/ZoneMinder/patches/02_destdir-fix.patch
index 759e3e494f..ffc7415796 100644
--- a/system/ZoneMinder/patches/02_destdir-fix.patch
+++ b/system/ZoneMinder/patches/02_destdir-fix.patch
@@ -1,15 +1,16 @@
---- ZoneMinder-1.24.2/Makefile.am.orig 2006-12-25 01:21:07.000000000 +0000
-+++ ZoneMinder-1.24.2/Makefile.am 2006-12-25 01:22:04.000000000 +0000
-@@ -23,9 +23,9 @@
+diff -Naur ZoneMinder-r3649.orig/Makefile.am ZoneMinder-r3649/Makefile.am
+--- ZoneMinder-r3649.orig/Makefile.am 2011-05-20 11:46:14.321490000 +0200
++++ ZoneMinder-r3649/Makefile.am 2012-06-20 14:55:04.474019380 +0200
+@@ -21,9 +21,9 @@
# Yes, you are correct. This is a HACK!
install-data-hook:
( cd $(DESTDIR)$(sysconfdir); chown $(webuser):$(webgroup) $(sysconf_DATA); chmod 600 $(sysconf_DATA) )
-- -( if ! test -e $(RUNDIR); then mkdir $(RUNDIR); fi )
-- ( if ! test -e $(ZM_RUNDIR); then mkdir $(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(ZM_RUNDIR); chmod u+w $(ZM_RUNDIR) )
-+ -( if ! test -e $(DESTDIR)$(RUNDIR); then @mkdir_p@ $(DESTDIR)$(RUNDIR); fi )
-+ ( if ! test -e $(DESTDIR)$(ZM_RUNDIR); then @mkdir_p@ $(DESTDIR)$(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_RUNDIR); chmod u+w $(DESTDIR)$(ZM_RUNDIR) )
+- ( if ! test -e $(ZM_RUNDIR); then mkdir -p $(ZM_RUNDIR); fi; if test "$(ZM_RUNDIR)" != "/var/run"; then chown $(webuser):$(webgroup) $(ZM_RUNDIR); chmod u+w $(ZM_RUNDIR); fi )
+- ( if ! test -e $(ZM_TMPDIR); then mkdir -m 700 -p $(ZM_TMPDIR); fi; if test "$(ZM_TMPDIR)" != "/tmp"; then chown $(webuser):$(webgroup) $(ZM_TMPDIR); chmod u+w $(ZM_TMPDIR); fi )
+- ( if ! test -e $(ZM_LOGDIR); then mkdir -p $(ZM_LOGDIR); fi; if test "$(ZM_LOGDIR)" != "/var/log"; then chown $(webuser):$(webgroup) $(ZM_LOGDIR); chmod u+w $(ZM_LOGDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_RUNDIR); then mkdir -p $(DESTDIR)$(ZM_RUNDIR); fi; if test "$(ZM_RUNDIR)" != "/var/run"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_RUNDIR); chmod u+w $(DESTDIR)$(ZM_RUNDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_TMPDIR); then mkdir -m 700 -p $(DESTDIR)$(ZM_TMPDIR); fi; if test "$(ZM_TMPDIR)" != "/tmp"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_TMPDIR); chmod u+w $(DESTDIR)$(ZM_TMPDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_LOGDIR); then mkdir -p $(DESTDIR)$(ZM_LOGDIR); fi; if test "$(ZM_LOGDIR)" != "/var/log"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_LOGDIR); chmod u+w $(DESTDIR)$(ZM_LOGDIR); fi )
uninstall-hook:
@-( cd $(DESTDIR)$(webdir); rm -rf events graphics images sounds temp )
-- @-( rm -rf $(ZM_RUNDIR) )
-+ @-( rm -rf $(DESTDIR)$(ZM_RUNDIR) )
diff --git a/system/ZoneMinder/patches/03_libjpegv8.patch b/system/ZoneMinder/patches/03_libjpegv8.patch
deleted file mode 100644
index 6f74e59640..0000000000
--- a/system/ZoneMinder/patches/03_libjpegv8.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- ZoneMinder-1.24.2/src/zm_jpeg.h~ 2009-03-20 13:07:00.000000000 +0100
-+++ ZoneMinder-1.24.2/src/zm_jpeg.h 2010-02-09 22:58:08.576509968 +0100
-@@ -36,5 +36,5 @@
- void zm_jpeg_emit_message( j_common_ptr cinfo, int msg_level );
-
- // Prototypes for memory compress/decompression object */
--void jpeg_mem_src(j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size );
--void jpeg_mem_dest(j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size );
-+void zm_jpeg_mem_src(j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size );
-+void zm_jpeg_mem_dest(j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size );
---- ZoneMinder-1.24.2/src/zm_jpeg.c~ 2009-03-20 13:07:00.000000000 +0100
-+++ ZoneMinder-1.24.2/src/zm_jpeg.c 2010-02-09 22:58:34.660048754 +0100
-@@ -173,7 +173,7 @@
- * for closing it after finishing compression.
- */
-
--void jpeg_mem_dest (j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size )
-+void zm_jpeg_mem_dest (j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size )
- {
- mem_dest_ptr dest;
-
-@@ -350,7 +350,7 @@
- * for closing it after finishing decompression.
- */
-
--void jpeg_mem_src( j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size )
-+void zm_jpeg_mem_src( j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size )
- {
- mem_src_ptr src;
-
---- ZoneMinder-1.24.2/src/zm_image.cpp~ 2009-05-25 20:04:00.000000000 +0200
-+++ ZoneMinder-1.24.2/src/zm_image.cpp 2010-02-09 22:58:53.219635716 +0100
-@@ -461,7 +461,7 @@
- return( false );
- }
-
-- jpeg_mem_src( cinfo, inbuffer, inbuffer_size );
-+ zm_jpeg_mem_src( cinfo, inbuffer, inbuffer_size );
-
- jpeg_read_header( cinfo, TRUE );
-
-@@ -523,7 +523,7 @@
- jpeg_create_compress( cinfo );
- }
-
-- jpeg_mem_dest( cinfo, outbuffer, outbuffer_size );
-+ zm_jpeg_mem_dest( cinfo, outbuffer, outbuffer_size );
-
- cinfo->image_width = width; /* image width and height, in pixels */
- cinfo->image_height = height;
diff --git a/system/ZoneMinder/patches/04_streaming-update.patch b/system/ZoneMinder/patches/04_streaming-update.patch
deleted file mode 100644
index 067158cccd..0000000000
--- a/system/ZoneMinder/patches/04_streaming-update.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- original/web/includes/functions.php 2009-05-08 12:17:10.000000000 +0300
-+++ patched/web/includes/functions.php 2010-04-13 22:44:27.000000000 +0300
-@@ -820,7 +820,7 @@
- $version = $logVersion[1];
- $browser = 'konqueror';
- }
-- elseif (ereg( 'Opera ([0-9].[0-9]{1,2})',$_SERVER['HTTP_USER_AGENT'],$logVersion))
-+ elseif (ereg( 'Opera/([0-9].[0-9]{1,2})',$_SERVER['HTTP_USER_AGENT'],$logVersion))
- {
- $version = $logVersion[1];
- $browser = 'opera';
-@@ -844,6 +844,18 @@
- return( $browser == "mozilla" );
- }
-
-+function isOpera()
-+{
-+ getBrowser( $browser, $version );
-+ return( $browser == "opera" );
-+}
-+
-+function isSafari()
-+{
-+ getBrowser( $browser, $version );
-+ return( $browser == "safari" );
-+}
-+
- function isKonqueror()
- {
- getBrowser( $browser, $version );
-@@ -875,7 +887,7 @@
-
- function canStreamNative()
- {
-- return( ZM_CAN_STREAM == "yes" || ( ZM_CAN_STREAM == "auto" && (isNetscape() || isKonqueror()) ) );
-+ return( ZM_CAN_STREAM == "yes" || ( ZM_CAN_STREAM == "auto" && (isNetscape() || isKonqueror() || isOpera() || isSafari()) ) );
- }
-
- function canStreamApplet()
diff --git a/system/ZoneMinder/patches/zm_build_fix.patch b/system/ZoneMinder/patches/zm_build_fix.patch
deleted file mode 100644
index 164a106893..0000000000
--- a/system/ZoneMinder/patches/zm_build_fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -u -ru ZoneMinder-1.24.2-old//src/zm_utils.cpp ZoneMinder-1.24.2/src/zm_utils.cpp
---- ZoneMinder-1.24.2-old//src/zm_utils.cpp 2010-06-03 01:34:27.981235559 +0300
-+++ ZoneMinder-1.24.2/src/zm_utils.cpp 2010-06-03 01:44:52.108291327 +0300
-@@ -20,6 +20,7 @@
- //#include "zm_debug.h"
- #include "zm_utils.h"
-
-+#include <cstdio>
- #include <stdarg.h>
-
- const std::string stringtf( const char *format, ... )
diff --git a/system/ZoneMinder/patches/zm_create.sql.in.patch b/system/ZoneMinder/patches/zm_create.sql.in.patch
deleted file mode 100644
index 5441de6423..0000000000
--- a/system/ZoneMinder/patches/zm_create.sql.in.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git ZoneMinder-1.24.2/db/zm_create.sql.in ZoneMinder-1.24.2-ta/db/zm_create.sql.in
-index fc7eb5d..e2bda24 100644
---- ZoneMinder-1.24.2/db/zm_create.sql.in
-+++ ZoneMinder-1.24.2-ta/db/zm_create.sql.in
-@@ -642,7 +642,7 @@ insert into Config set Id = 38, Name = 'ZM_HTTP_TIMEOUT', Value = '2500', Type =
- insert into Config set Id = 39, Name = 'ZM_MIN_RTP_PORT', Value = '40200', Type = 'integer', DefaultValue = '40200', Hint = 'integer', Pattern = '(?-xism:^(\d+)$)', Format = ' $1 ', Prompt = 'Minimum port that ZoneMinder will listen for RTP traffic on', Help = 'When ZoneMinder communicates with MPEG4 capable cameras using RTP with the unicast method it must open ports for the camera to connect back to for control and streaming purposes. This setting specifies the minimum port number that ZoneMinder will use. Ordinarily two adjacent ports are used for each camera, one for control packets and one for data packets. This port should be set to an even number, you may also need to open up a hole in your firewall to allow cameras to connect back if you wish to use unicasting.', Category = 'network', Readonly = '0', Requires = '';
- insert into Config set Id = 40, Name = 'ZM_MAX_RTP_PORT', Value = '40499', Type = 'integer', DefaultValue = '40499', Hint = 'integer', Pattern = '(?-xism:^(\d+)$)', Format = ' $1 ', Prompt = 'Maximum port that ZoneMinder will listen for RTP traffic on', Help = 'When ZoneMinder communicates with MPEG4 capable cameras using RTP with the unicast method it must open ports for the camera to connect back to for control and streaming purposes. This setting specifies the maximum port number that ZoneMinder will use. Ordinarily two adjacent ports are used for each camera, one for control packets and one for data packets. This port should be set to an even number, you may also need to open up a hole in your firewall to allow cameras to connect back if you wish to use unicasting. You should also ensure that you have opened up at least two ports for each monitor that will be connecting to unicasting network cameras.', Category = 'network', Readonly = '0', Requires = '';
- insert into Config set Id = 41, Name = 'ZM_OPT_FFMPEG', Value = '1', Type = 'boolean', DefaultValue = 'yes', Hint = 'yes|no', Pattern = '(?i-xsm:^([yn]))', Format = ' ($1 =~ /^y/) ? \"yes\" : \"no\" ', Prompt = 'Is the ffmpeg video encoder/decoder installed', Help = 'ZoneMinder can optionally encode a series of video images into an MPEG encoded movie file for viewing, downloading or storage. This option allows you to specify whether you have the ffmpeg tools installed. Note that creating MPEG files can be fairly CPU and disk intensive and is not a required option as events can still be reviewed as video streams without it.', Category = 'images', Readonly = '0', Requires = '';
--insert into Config set Id = 42, Name = 'ZM_PATH_FFMPEG', Value = '/usr/local/bin/ffmpeg', Type = 'string', DefaultValue = '/usr/local/bin/ffmpeg', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to (optional) ffmpeg mpeg encoder', Help = 'This path should point to where ffmpeg has been installed.', Category = 'images', Readonly = '0', Requires = 'ZM_OPT_FFMPEG=1';
-+insert into Config set Id = 42, Name = 'ZM_PATH_FFMPEG', Value = '/usr/bin/ffmpeg', Type = 'string', DefaultValue = '/usr/bin/ffmpeg', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to (optional) ffmpeg mpeg encoder', Help = 'This path should point to where ffmpeg has been installed.', Category = 'images', Readonly = '0', Requires = 'ZM_OPT_FFMPEG=1';
- insert into Config set Id = 43, Name = 'ZM_FFMPEG_INPUT_OPTIONS', Value = '', Type = 'string', DefaultValue = '', Hint = 'string', Pattern = '(?-xism:^(.+)$)', Format = ' $1 ', Prompt = 'Additional input options to ffmpeg', Help = 'Ffmpeg can take many options on the command line to control the quality of video produced. This option allows you to specify your own set that apply to the input to ffmpeg (options that are given before the -i option). Check the ffmpeg documentation for a full list of options which may be used here.', Category = 'images', Readonly = '0', Requires = 'ZM_OPT_FFMPEG=1';
- insert into Config set Id = 44, Name = 'ZM_FFMPEG_OUTPUT_OPTIONS', Value = '-r 25', Type = 'string', DefaultValue = '-r 25', Hint = 'string', Pattern = '(?-xism:^(.+)$)', Format = ' $1 ', Prompt = 'Additional output options to ffmpeg', Help = 'Ffmpeg can take many options on the command line to control the quality of video produced. This option allows you to specify your own set that apply to the output from ffmpeg (options that are given after the -i option). Check the ffmpeg documentation for a full list of options which may be used here. The most common one will often be to force an output frame rate supported by the video encoder.', Category = 'images', Readonly = '0', Requires = 'ZM_OPT_FFMPEG=1';
- insert into Config set Id = 45, Name = 'ZM_FFMPEG_FORMATS', Value = 'mpg mpeg wmv asf avi* mov swf 3gp**', Type = 'string', DefaultValue = 'mpg mpeg wmv asf avi* mov swf 3gp**', Hint = 'string', Pattern = '(?-xism:^(.+)$)', Format = ' $1 ', Prompt = 'Formats to allow for ffmpeg video generation', Help = 'Ffmpeg can generate video in many different formats. This option allows you to list the ones you want to be able to select. As new formats are supported by ffmpeg you can add them here and be able to use them immediately. Adding a \'*\' after a format indicates that this will be the default format used for web video, adding \'**\' defines the default format for phone video.', Category = 'images', Readonly = '0', Requires = 'ZM_OPT_FFMPEG=1';
-@@ -653,11 +653,11 @@ insert into Config set Id = 49, Name = 'ZM_RECORD_DIAG_IMAGES', Value = '0', Typ
- insert into Config set Id = 50, Name = 'ZM_EXTRA_DEBUG', Value = '0', Type = 'boolean', DefaultValue = 'no', Hint = 'yes|no', Pattern = '(?i-xsm:^([yn]))', Format = ' ($1 =~ /^y/) ? \"yes\" : \"no\" ', Prompt = 'Switch additional debugging on', Help = 'ZoneMinder binary components usually have several levels of debug information they can output. Normally this is set to a fairly low level to avoid filling logs too quickly. This options lets you switch on other options that allow you to configure additional debug information to be output. Components will pick up this instruction when they are restarted.', Category = 'debug', Readonly = '0', Requires = '';
- insert into Config set Id = 51, Name = 'ZM_EXTRA_DEBUG_TARGET', Value = '', Type = 'string', DefaultValue = '', Hint = 'string', Pattern = '(?-xism:^(.+)$)', Format = ' $1 ', Prompt = 'What components should have extra debug enabled', Help = 'There are three scopes of debug available. Leaving this option blank means that all components will use extra debug (not recommended). Setting this option to \'_<component>\', e.g. _zmc, will limit extra debug to that component only. Setting this option to \'_<component>_<identity>\', e.g. \'_zmc_m1\' will limit extra debug to that instance of the component only. This is ordinarily what you probably want to do.', Category = 'debug', Readonly = '0', Requires = 'ZM_EXTRA_DEBUG=1';
- insert into Config set Id = 52, Name = 'ZM_EXTRA_DEBUG_LEVEL', Value = '0', Type = 'integer', DefaultValue = '0', Hint = '0|1|2|3|4|5|6|7|8|9', Pattern = '(?-xism:^(\d+)$)', Format = ' $1 ', Prompt = 'What level of extra debug should be enabled', Help = 'There are 9 levels of debug available, with higher numbers being more debug and level 0 being no debug. However not all levels are used by all components. Also if there is debug at a high level it is usually likely to be output at such a volume that it may obstruct normal operation. For this reason you should set the level carefully and cautiously until the degree of debug you wish to see is present.', Category = 'debug', Readonly = '0', Requires = 'ZM_EXTRA_DEBUG=1';
--insert into Config set Id = 53, Name = 'ZM_EXTRA_DEBUG_LOG', Value = '/tmp/zm_debug.log+', Type = 'string', DefaultValue = '/tmp/zm_debug.log+', Hint = 'string', Pattern = '(?-xism:^(.+)$)', Format = ' $1 ', Prompt = 'Where extra debug is output to', Help = 'Depending on your system configuration you may find that only errors, warning and informational messages are logged to your system log. This option allows you to specify an additional target for these messages and debug. This also has the advantage of partitioning debug for the component you are tracing, from messages from other components. Be warned however that if this is a simple filename and you are debugging several components then they will all try and write to the same file with undesirable consequences. Appending a \'+\' to the filename will cause the file to be created with a \'.<pid>\' suffix containing your process id. In this way debug from each run of a component is kept separate. This is the recommended setting as it will also prevent subsequent runs from overwriting the same log.', Category = 'debug', Readonly = '0', Requires = 'ZM_EXTRA_DEBUG=1';
-+insert into Config set Id = 53, Name = 'ZM_EXTRA_DEBUG_LOG', Value = '/var/log/zm/zm_debug.log+', Type = 'string', DefaultValue = '/var/log/zm/zm_debug.log+', Hint = 'string', Pattern = '(?-xism:^(.+)$)', Format = ' $1 ', Prompt = 'Where extra debug is output to', Help = 'Depending on your system configuration you may find that only errors, warning and informational messages are logged to your system log. This option allows you to specify an additional target for these messages and debug. This also has the advantage of partitioning debug for the component you are tracing, from messages from other components. Be warned however that if this is a simple filename and you are debugging several components then they will all try and write to the same file with undesirable consequences. Appending a \'+\' to the filename will cause the file to be created with a \'.<pid>\' suffix containing your process id. In this way debug from each run of a component is kept separate. This is the recommended setting as it will also prevent subsequent runs from overwriting the same log.', Category = 'debug', Readonly = '0', Requires = 'ZM_EXTRA_DEBUG=1';
- insert into Config set Id = 54, Name = 'ZM_DUMP_CORES', Value = '0', Type = 'boolean', DefaultValue = 'no', Hint = 'yes|no', Pattern = '(?i-xsm:^([yn]))', Format = ' ($1 =~ /^y/) ? \"yes\" : \"no\" ', Prompt = 'Create core files on unexpected process failure.', Help = 'When an unrecoverable error occurs in a ZoneMinder binary process is has traditionally been trapped and the details written to logs to aid in remote analysis. However in some cases it is easier to diagnose the error if a core file, which is a memory dump of the process at the time of the error, is created. This can be interactively analysed in the debugger and may reveal more or better information than that available from the logs. This option is recommended for advanced users only otherwise leave at the default. Note using this option to trigger core files will mean that there will be no indication in the binary logs that a process has died, they will just stop, however the zmdc log will still contain an entry. Also note that you may have to explicitly enable core file creation on your system via the \'ulimit -c\' command or other means otherwise no file will be created regardless of the value of this option.', Category = 'debug', Readonly = '0', Requires = '';
- insert into Config set Id = 55, Name = 'ZM_PATH_MAP', Value = '/dev/shm', Type = 'string', DefaultValue = '/dev/shm', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to the mapped memory files that that ZoneMinder can use', Help = 'ZoneMinder has historically used IPC shared memory for shared data between processes. This has it\'s advantages and limitations. This version of ZoneMinder can use an alternate method, mapped memory, instead with can be enabled with the --enable--mmap directive to configure. This requires less system configuration and is generally more flexible. However it requires each shared data segment to map onto a filesystem file. This option indicates where those mapped files go. You should ensure that this location has sufficient space for these files and for the best performance it should be a tmpfs file system or ramdisk otherwise disk access may render this method slower than the regular shared memory one.', Category = 'paths', Readonly = '0', Requires = '';
--insert into Config set Id = 56, Name = 'ZM_PATH_SOCKS', Value = '/tmp', Type = 'string', DefaultValue = '/tmp', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to the various Unix domain socket files that ZoneMinder uses', Help = 'ZoneMinder generally uses Unix domain sockets where possible. This reduces the need for port assignments and prevents external applications from possibly compromising the daemons. However each Unix socket requires a .sock file to be created. This option indicates where those socket files go.', Category = 'paths', Readonly = '0', Requires = '';
--insert into Config set Id = 57, Name = 'ZM_PATH_LOGS', Value = '/tmp', Type = 'string', DefaultValue = '/tmp', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to the various logs that the ZoneMinder daemons generate', Help = 'There are various daemons that are used by ZoneMinder to perform various tasks. Most generate helpful log files and this is where they go. They can be deleted if not required for debugging.', Category = 'paths', Readonly = '0', Requires = '';
-+insert into Config set Id = 56, Name = 'ZM_PATH_SOCKS', Value = '/var/run/zm', Type = 'string', DefaultValue = '/var/run/zm', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to the various Unix domain socket files that ZoneMinder uses', Help = 'ZoneMinder generally uses Unix domain sockets where possible. This reduces the need for port assignments and prevents external applications from possibly compromising the daemons. However each Unix socket requires a .sock file to be created. This option indicates where those socket files go.', Category = 'paths', Readonly = '0', Requires = '';
-+insert into Config set Id = 57, Name = 'ZM_PATH_LOGS', Value = '/var/log/zm', Type = 'string', DefaultValue = '/var/log/zm', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to the various logs that the ZoneMinder daemons generate', Help = 'There are various daemons that are used by ZoneMinder to perform various tasks. Most generate helpful log files and this is where they go. They can be deleted if not required for debugging.', Category = 'paths', Readonly = '0', Requires = '';
- insert into Config set Id = 58, Name = 'ZM_PATH_SWAP', Value = '/tmp', Type = 'string', DefaultValue = '/tmp', Hint = '/absolute/path/to/somewhere', Pattern = '(?-xism:^((?:/[^/]*)+?)/?$)', Format = ' $1 ', Prompt = 'Path to location for temporary swap images used in streaming', Help = 'Buffered playback requires temporary swap images to be stored for each instance of the streaming daemons. This option determines where these images will be stored. The images will actually be stored in sub directories beneath this location and will be automatically cleaned up after a period of time.', Category = 'paths', Readonly = '0', Requires = '';
- insert into Config set Id = 59, Name = 'ZM_WEB_TITLE_PREFIX', Value = 'ZM', Type = 'string', DefaultValue = 'ZM', Hint = 'string', Pattern = '(?-xism:^(.+)$)', Format = ' $1 ', Prompt = 'The title prefix displayed on each window', Help = 'If you have more than one installation of ZoneMinder it can be helpful to display different titles for each one. Changing this option allows you to customise the window titles to include further information to aid identification.', Category = 'web', Readonly = '0', Requires = '';
- insert into Config set Id = 60, Name = 'ZM_WEB_RESIZE_CONSOLE', Value = '1', Type = 'boolean', DefaultValue = 'yes', Hint = 'yes|no', Pattern = '(?i-xsm:^([yn]))', Format = ' ($1 =~ /^y/) ? \"yes\" : \"no\" ', Prompt = 'Should the console window resize itself to fit', Help = 'Traditionally the main ZoneMinder web console window has resized itself to shrink to a size small enough to list only the monitors that are actually present. This is intended to make the window more unobtrusize but may not be to everyones tastes, especially if opened in a tab in browsers which support this kind if layout. Switch this option off to have the console window size left to the users preference', Category = 'web', Readonly = '0', Requires = '';