summaryrefslogtreecommitdiffstats
path: root/system/glances
diff options
context:
space:
mode:
author Philip Lacroix <philnx@bluebottle.com>2014-03-11 20:53:39 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-03-12 12:42:51 -0500
commit7c593e18507a92fc4f177fb587fd232e14cacdc8 (patch)
treeac263843c01392174a66e5318b7836389d7ae531 /system/glances
parenta37fc6bd03f81ca48a4086530b719214283724b1 (diff)
downloadslackbuilds-7c593e18507a92fc4f177fb587fd232e14cacdc8.tar.gz
slackbuilds-7c593e18507a92fc4f177fb587fd232e14cacdc8.tar.xz
system/glances: Updated for version 1.7.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/glances')
-rw-r--r--system/glances/README6
-rw-r--r--system/glances/doinst.sh3
-rw-r--r--system/glances/glances.SlackBuild29
-rw-r--r--system/glances/glances.info6
4 files changed, 23 insertions, 21 deletions
diff --git a/system/glances/README b/system/glances/README
index 2e448c9127..b393b94c0b 100644
--- a/system/glances/README
+++ b/system/glances/README
@@ -12,6 +12,6 @@ statistical values from key elements, like CPU, load average, memory,
network, disks, file systems, processes, etc.
Optional dependencies are Jinja2 (for HTML output), hddtemp (for HHD
-temperature monitoring support) and python3.
-Others not available on SBo are pysensors (for HW monitoring support)
-and batinfo (for battery monitoring support).
+temperature monitoring support) and python3. Others not available on SBo
+are pysensors (for HW monitoring support) and batinfo (for battery
+monitoring support).
diff --git a/system/glances/doinst.sh b/system/glances/doinst.sh
index 3ec38c6c20..d1bde8d89b 100644
--- a/system/glances/doinst.sh
+++ b/system/glances/doinst.sh
@@ -1,14 +1,11 @@
config() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
rm $NEW
fi
- # Otherwise, we leave the .new copy for the admin to consider...
}
config etc/glances/glances.conf.new
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
index b9ef3e5de8..10fd605103 100644
--- a/system/glances/glances.SlackBuild
+++ b/system/glances/glances.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for glances
-# Copyright 2013 Philip Lacroix <philnx at bluebottle dot com>
+# Copyright 2013-2014 Philip Lacroix <philnx at bluebottle dot com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=glances
-VERSION=${VERSION:-1.7.2}
+VERSION=${VERSION:-1.7.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,7 +46,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/v$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/v$VERSION.tar.gz
+
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -55,6 +56,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+PRGUSR=$PKG/usr
+PRGETC=$PKG/etc/$PRGNAM
+PRGSHR=$PKG/usr/share
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
python setup.py install --root=$PKG
# Python 3 support
@@ -62,19 +68,18 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-# Don't clobber configuration files
-mv $PKG/etc/$PRGNAM/$PRGNAM.conf $PKG/etc/$PRGNAM/$PRGNAM.conf.new
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/share/man $PKG/usr/
-gzip -9 $PKG/usr/man/man?/*.?
+mv $PRGETC/$PRGNAM.conf $PRGETC/$PRGNAM.conf.new
+
+mv $PRGSHR/man $PKG/usr/
+gzip -9 $PRGUSR/man/man?/*.?
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
-rm -rf $PKG/usr/share/doc
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PRGDOC
+mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
+rm -rf $PRGSHR
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/system/glances/glances.info b/system/glances/glances.info
index d8498fc031..6b35dad1e6 100644
--- a/system/glances/glances.info
+++ b/system/glances/glances.info
@@ -1,8 +1,8 @@
PRGNAM="glances"
-VERSION="1.7.2"
+VERSION="1.7.4"
HOMEPAGE="https://github.com/nicolargo/glances"
-DOWNLOAD="https://github.com/nicolargo/glances/archive/v1.7.2.tar.gz"
-MD5SUM="71fe3c9be2490095e8eeb07f172ffe2e"
+DOWNLOAD="https://github.com/nicolargo/glances/archive/v1.7.4.tar.gz"
+MD5SUM="2062e70326f4c2eb9595c53c59d55047"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="psutil pysetuptools"