summaryrefslogtreecommitdiffstats
path: root/system/s3ql
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2015-09-10 01:53:41 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-10 01:53:41 +0700
commitb03c99da6436f7843bd45b4383b837b40fb7cd6a (patch)
treefce9e78719be916f06dcbcc5c859c130466333f1 /system/s3ql
parented597a3c1c3e714b7c7e3577c424117e368878e3 (diff)
downloadslackbuilds-b03c99da6436f7843bd45b4383b837b40fb7cd6a.tar.gz
slackbuilds-b03c99da6436f7843bd45b4383b837b40fb7cd6a.tar.xz
system/s3ql: Added (Online Storage File System).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/s3ql')
-rw-r--r--system/s3ql/README17
-rw-r--r--system/s3ql/s3ql.SlackBuild96
-rw-r--r--system/s3ql/s3ql.info10
-rw-r--r--system/s3ql/slack-desc19
4 files changed, 142 insertions, 0 deletions
diff --git a/system/s3ql/README b/system/s3ql/README
new file mode 100644
index 0000000000..279967cf04
--- /dev/null
+++ b/system/s3ql/README
@@ -0,0 +1,17 @@
+s3ql: S3QL is a file system that stores all its data online using storage
+s3ql: services like Google Storage, Amazon S3, or OpenStack. S3QL
+s3ql: effectively provides a hard disk of dynamic, infinite capacity that
+s3ql: can be accessed from any computer with internet access running
+Linux, FreeBSD or OS-X.
+
+S3QL is a standard conforming, full featured UNIX file system that is
+conceptually indistinguishable from any local file system. Furthermore,
+S3QL has additional features like compression, encryption, data
+de-duplication, immutable trees and snapshotting which make it especially
+suitable for online backup and archival.
+
+S3QL is designed to favor simplicity and elegance over performance and
+feature-creep. Care has been taken to make the source code as readable and
+serviceable as possible. Solid error detection and error handling have
+been included from the very first line, and S3QL comes with extensive
+automated test cases for all its components.
diff --git a/system/s3ql/s3ql.SlackBuild b/system/s3ql/s3ql.SlackBuild
new file mode 100644
index 0000000000..628dfb8069
--- /dev/null
+++ b/system/s3ql/s3ql.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for "s3ql".
+
+# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=s3ql
+VERSION=${VERSION:-2.14}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python3 setup.py install --root $PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/$PRGNAM
+mv $PKG/usr/share/man $PKG/usr
+cp -ar contrib $PKG/usr/share/$PRGNAM
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changes.txt LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/s3ql/s3ql.info b/system/s3ql/s3ql.info
new file mode 100644
index 0000000000..a2f8e348d4
--- /dev/null
+++ b/system/s3ql/s3ql.info
@@ -0,0 +1,10 @@
+PRGNAM="s3ql"
+VERSION="2.14"
+HOMEPAGE="https://bitbucket.org/nikratio/s3ql/"
+DOWNLOAD="https://bitbucket.org/nikratio/s3ql/downloads/s3ql-2.14.tar.bz2"
+MD5SUM="246b32196e5c9b3e8aac135535615c08"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-dugong python3-defusedxml python3-pycrypto python-requests llfuse apsw"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/system/s3ql/slack-desc b/system/s3ql/slack-desc
new file mode 100644
index 0000000000..d3596a022e
--- /dev/null
+++ b/system/s3ql/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+s3ql: s3ql (Online Storage File System)
+s3ql:
+s3ql: S3QL is a file system that stores all its data online using storage
+s3ql: services like Google Storage, Amazon S3, or OpenStack. S3QL
+s3ql: effectively provides a hard disk of dynamic, infinite capacity that
+s3ql: can be accessed from any computer with internet access.
+s3ql:
+s3ql: Homepage: https://bitbucket.org/nikratio/s3ql/
+s3ql:
+s3ql:
+s3ql: