summaryrefslogtreecommitdiffstats
path: root/system/vlock/vlock.SlackBuild
diff options
context:
space:
mode:
author Chris Abela <chris.abela@maltats.com>2010-05-13 00:42:21 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:42:21 +0200
commitdf4ccaeb30506449f1c4056ee5690af48ff658c7 (patch)
treeb6501b467f06fff823d990991f2c8ca2eabb48d8 /system/vlock/vlock.SlackBuild
parenta5ec78694960959c9aec67b28bca0f30afd46eeb (diff)
downloadslackbuilds-df4ccaeb30506449f1c4056ee5690af48ff658c7.tar.gz
slackbuilds-df4ccaeb30506449f1c4056ee5690af48ff658c7.tar.xz
system/vlock: Updated for version 2.2.2
Diffstat (limited to 'system/vlock/vlock.SlackBuild')
-rw-r--r--system/vlock/vlock.SlackBuild45
1 files changed, 28 insertions, 17 deletions
diff --git a/system/vlock/vlock.SlackBuild b/system/vlock/vlock.SlackBuild
index 8d8a7e2e25..9693d50ed5 100644
--- a/system/vlock/vlock.SlackBuild
+++ b/system/vlock/vlock.SlackBuild
@@ -3,9 +3,10 @@
# Slackware build script for vlock
# Written by Menno E. Duursma <druiloor@zonnet.nl>
# Modified by Robby Workman <rworkman@slackbuilds.org>
+# Modified by Chris Abela <chris.abela@maltats.com>
PRGNAM=vlock
-VERSION=2.1
+VERSION=2.2.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -15,10 +16,17 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+VLOCK_GRP=${VLOCK_GROUP:-wheel}
+
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e # Exit on most errors
@@ -30,27 +38,30 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . -type d -exec chmod 755 {} \;
-find . -type f -exec chmod a-s,go-w {} \;
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-# Patch to use /etc/shadow directly rather then via PAM
-# and install setgid tty/shadow, rather then setuid root
-patch -p1 < $CWD/config.mk.diff
-patch -p1 < $CWD/Makefile.diff
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --enable-shadow \
-CFLAGS=$SLKCFLAGS make
-make install DESTDIR=$PKG
+make
+make install DESTDIR=$PKG VLOCK_GROUP="$VLOCK_GRP"
( cd $PKG
- find . -type f \
- | xargs file \
- | grep "executable" \
- | grep "ELF" \
- | cut -f 1 -d : \
- | xargs strip
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
-mv $PKG/usr/share/man $PKG/usr && rmdir $PKG/usr/share
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
@@ -64,4 +75,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}